Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даны стороны прямоугольника a и b и радиус окружности R. Влезет ли прямоугольник в окружность? Решить в паскале. Помогите пожалуйста))

5-9 класс

ЮлияЧернова 24 янв. 2014 г., 4:26:05 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chistyakovatc
24 янв. 2014 г., 5:08:41 (10 лет назад)

Программа предыдущего пользователя не совсем верна;) 

Var

Begin

readln (a);

readln (b);

readln (r);

if (a>2*r) and (b>2*r) then writeln ('влезет') else writeln (' не влезет');

end.

Сама сегодня решала! Однозначно правильно. 

Р.S. Дарина, ты, что-ли? Пиши в лс:)

+ 0 -
VasiliKap
24 янв. 2014 г., 7:53:28 (10 лет назад)

program n2;

var S1,S2a,b,R:integer;

s1:=pi*sqrt(R);

s2:=a*b;

if s1>s2 then writeln('Влезет') else writeln('Не влезет')

end;

end.

Ответить

Другие вопросы из категории

Какой пункт не является действием к выполнению основных файловых операций:

А) копирование;
B) переименование;
C) форматирование;
D) удаление.

помогите сделать я хочу быть на 1 месте тему "Я горжусь своей страной" (чем, на Ваш взгляд, может гордиться Россия; почему Вы гордитесь нашей

страной; считаете ли Вы себя патриотом своей страны и др.), оформленное по следующим правилам: объем работы - максимум 2 страницы, шрифт - Times New Roman кегль - 14 пунктов межстрочное расстояние - 1,5 абзацный отступ - 1 см выравнивание основного текста - по ширине ,

Читайте также

1)Напишите программу,которая запрашивает значения двух переменных и выводит их разность.Приглашение к вводу каждого числа произведите в отдельных

строках.Вывод результата сопроводите пояснениями
2)Напишите программу ввода трех величин( А,В,С) на одной строке,рассчитайте и выдайте на экран на отдельной строке значение выражения: (А*В)/3,14 +3С.
3)Напишите программу вычисления длины окружности и площади круга одного и того же заданного радиуса R.
Решать на паскале...Помогите пожалуйста(((

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

РЕШИТЕ ПОЖАЛУЙСТА!!! Сформировать массив множителей заданного числа. Язык программирования - паскаль.ПОМОГИТЕ, ПОЖАЛУЙСТА!!! дана матрица

B(4,3). Заменить отрицательные элементы произведением положительных элементов. Языка программирования - паскаль.

Задача 35. Решить Паскалем.

Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и выписанной окружностей.



Вы находитесь на странице вопроса "Даны стороны прямоугольника a и b и радиус окружности R. Влезет ли прямоугольник в окружность? Решить в паскале. Помогите пожалуйста))", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.