Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите срочно надо.Вывести массив М девяти элементов. Вычислить разность между минимальными и максимальными элементами. Использовать подпрограммы

10-11 класс

Nonnaetta 23 февр. 2017 г., 3:24:17 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mil8nium
23 февр. 2017 г., 5:28:24 (7 лет назад)

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

void show_raznost(vector<int> vctor);

int main ()
{
vector <int> my_vector;

for(int i=1;i<=9;i++)
{
int num ;
cin>>num;
my_vector.push_back(num);
}

sort(my_vector.begin(), my_vector.end());

show_raznost(my_vector);

}

void show_raznost(vector<int> vctor)
{
cout<<vctor[0]-vctor[8];
}

Ответить

Другие вопросы из категории

Исправьте программу, она почему-то при выполнении не приходит к результату, то есть выполняется, но закончить выполнение не может. ошибка где-то в цикле

как я понимаю.

сама задание выглядит так:

Задан массив из н элементов. определить

1) сколько различных элементов в массиве

2) Удалить повторные появления каждого элемента

вот текст программы

program p;
var n, i, k, j: integer;
a:array[1..50] of integer;
begin
readln (n);
for i:=1 to n do
readln (a[i]);
i:=1;
while i<=n-1 do
begin
j:=i+1;
while j<=n do
if a[i]=a[j] then
begin
for k:=j+1 to n do
a[k-1]:=a[k];
n:=n-1
end
else j:=j+1;
end;
writeln (n);
for i:=1 to n do
writeln (a[i])
end.

МНОГО ПУНКТОВ. (Линейное) Программирование.ПАСКАЛЬ. Задачи ОЧЕНЬ ЛЕГКИЕ, пропустила много. Хочу разобраться. БОЛЬШОЕ СПАСИБО ЗА ПРАВИЛЬНОЕ

РЕШЕНИЕ)

Карточка 1.

1. Вычислите дробную часть среднего арифметического трех заданных чисел.

2. Составьте программу вычисления идеального веса человека по его росту, при условии. что идеальный вес (кг)=(рост(см) - 100

3. Рассчитайте, сколько очков набрала команда по хоккею, если известно, что m встреч онавыиграла (2 очка), n встреч она проиграла (0 очков) и k встреч - ничья (1 очко).

4.1 Дано целое число. Определить является ли оно четным.

4.2 Дано целое число. Определить оканчивается ли оно цифрой 7.

Карточка 2. ( необходимо знание формул по физике)

1. Даны объем и массы двух тел из разных материалов. Материал какого из тел имеет большую плотность?

2. Известны напряжения двух не соединенных друг с другом участков электрическлй цепи и напряжения на каждом из них. По какому участку протекает меньший ток?

1 .Запишите натуральный ряд чисел в двоичной системе счисления (до четырех разрядов)

2.переведите числа из одной системы счисления в другую :
10101^2=А^10
10101^8=A^10
10101^16=A^10
3.Какое из чисел 110011^2 , 111^4,35^8 является наибольшим а какое наименьшим ?

Читайте также

1)Вывести массив 4*4

1 3 5 7
1 3 5 7
1 3 5 7
1 3 5 7
2)Массив 4*4
0010
0100
0000
1100
Подсчитать количество нулей и единиц
3)Случайным образом вывести массив 5*5 (50)
A[I,j]:= random (50);
Сумму элементов массива

Ребят!!! Срочно!!! Помогите с информатикой пожалуйста

Вычислить разность между наибольштм и наименьшим элементами массива

Составьте программу, которая для одномерного массива, содержащего n элементов вычисляет и отображает: 1) сумму элементов массива; 2)произведение чётных

элементов; 3) сумму элементов которые делятся на 3; 4) минимальный и максимальный элемент. (используя procedure или function, но чтоб была рекурсия)ПОЖАЛУЙСТА ПОМОГИТЕ ВОПРОС ЖИЗНИ И СМЕРТИ!!

Помогите, пожалуйста!! Язык программирования Паскаль.

1) Найти количество отрицательных элементов в массиве А [3,8].
2) Заполнит и вывести массив Р [6,7], запросить номер строки и вывести её на экран.
3) Заполнить и вывести массив Р [6,7], запросить номер строки, заменить все её элементы на 5 и вывести новый массив.
4) В квадратной матрице А [10,10] заменить элементы главной диагонали на 0.

Всё нужно очень срочно



Вы находитесь на странице вопроса "Помогите срочно надо.Вывести массив М девяти элементов. Вычислить разность между минимальными и максимальными элементами. Использовать подпрограммы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.