Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дано целое число. Вывести его строку-описание вида "отрицательное четное число","нулевое число"," положительное нечетное число" и т.д. в С++ (

10-11 класс

желательно с комментариями)

брянцева 12 марта 2014 г., 14:22:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Imdragon
12 марта 2014 г., 16:22:09 (10 лет назад)

#include<iostream.h>

#include<conio.h>

#include<stdio.h>

 

int main()

 

 {

 

      int b;                                 // наше число b

      clrscr();                           // очищаем экран 

 

      cout<<"Введите b: ";  // Выводим на экран приглашение ввести и  

      cin>>b;                          // b присвиваем введённое значение  

 

         // если b=0 то выводим соответствующее сообщение 

 

        if (b==0)      cout<<"Ноль Совсем Ноль \n "; 

 

       // если b<0 и остаток от деления на 2 =0 то это  отрицательное четное число

        if  ((b<0) && (b%2)==0) cout<<"отрицательное четное число \n ";  

 

// если b<0 и остаток от дления на 2 <>0 то это  отрицательное нечетное число

 if  ((b<0) && (b%2)!=0) cout<<"отрицательное нечетное число \n ";

 

   

 // если b>0 и остаток от деления на 2 =0 то это  положительное   четное число  

        if  ((b>0) && (b%2)==0) cout<<"положительное четное число \n ";  

 

   // если b>0 и остаток от деления на 2 <>0 то это  положительное  нечетное число     

        if  ((b>0) && (b%2)!=0) cout<<" положительное  нечетное число \n ";   

 

  getch();   // ждём нажатия на любую клавишу перед  закрытием

  return 0; // стандартный выход  

 

 

 

 

Ответить

Другие вопросы из категории

рисование символами в паскаль ABC. символы должны отделяться пробелами.

выведите на экран
*
*
*****
*****
*********
*********

Каждая буква шифруется двузначным или трехзначгым числом, в зависимости от того гласная она или согласная (при этом не ясно двузначным кодом шифруется

гласные или согласные буквы). Буквы е и ё объединены. Среди слов "крейсер", "уловка", "шалаш", "электричество", "преподаватель", "молоко" есть слова, зашифрованные следующими последоваетльностями: 2732101263310132, 391002810039, 104281032127100, 291032810327103. Каким кодом будет зашифровано слово "роутер" ?

1) На рисунке – схема дорог, связывающих города А, Б, В, Г, Д, Е, Ж, З, И, К. По каждой дороге можно двигаться только в одном направлении, указ

анном стрелкой. Сколько существует различных путей из города А в город К?

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число



Вы находитесь на странице вопроса "Дано целое число. Вывести его строку-описание вида "отрицательное четное число","нулевое число"," положительное нечетное число" и т.д. в С++ (", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.