Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана строка, содержащая не более двадцати латинских букв. Все вхождение «max» в ней заменить на «min» и «макс» на «мин». Подсчитать число таких замен

10-11 класс

Katusha696 20 окт. 2014 г., 11:48:03 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Мурзинцева
20 окт. 2014 г., 12:37:45 (9 лет назад)

uses crt;
var i,zi,zj:integer;
    s,n:String;
begin
clrscr;
repeat
writeln('Введите строку не больше 20 символов.');
readln(s);
until length(s) <=20;
for i:=1 to length(s) do
begin
if (s[i] = 'm') or (s[i]='м') then
 begin
      n:=copy(s,i,3);
      if n = 'max' then begin n:='min'; delete(s,i,3); insert(n,s,i); zi:=zi+1; end
      else
      begin
      

Ответить

Другие вопросы из категории

Определить сумму наибольшего и второго по

значению наименьшего элементов. Паскаль. Не через массивы.
У меня во внешнем файле есть последовательность из отрицательных и положительных чисел!
1, 2,-3, 4, 5, -6, 7, 8, -9, 10!
Наибольшее число 10, наименьшее число -9, второе по значению наименьшее -6! Я нашел наименьшее и наибольшее, но не пойму как найти второе по значению наименьшее, помогите)

Дан массив А(100). Распечать наименьше значение попарных сумм. Решите, пожалуйста!!!

(С использованием команда random или без неё).

Помогите, пожалуйста. Паскаль

Написать программу, которая выводит целые числа в промежутке от 1 до 50, кратные четырем и считает их количество, сумму и произведение.

составить блок схему по программе pascal program zadacha 3_1. var max,x,e:real; begin writeln('введите натуральное число x');readln(x);

writeln('введите число y');readln(y); if x>y then max:=x else max:=y; writeln('большее из двух =',max); end.

Читайте также

Ребята, помогите срочно!!!!) завтра экзамен, и надо принести домашнюю работу.....нужно написать программку в Delphi. вот задание...."Дана

строка, содержащая не более двадцати латинских букв. Все вхождение «max» в ней заменить на «min» и «макс» на «мин». Подсчитать число таких замен." Буду очень благодарен, если кто поможет. прикрепляю так же образец, как именно должен выглядеть код программы. Заранее всем кто поможет огромное СПАСИБО!!!!!!!!!!

Помогите, пожалуйста, решить задачу по информатике (с объяснениями): Задача 3. Экранная клавиатура КПК позволяет вводить символы русского

и английского алфавита прикосновением пера к экрану. Для переключения между заглавными и строчными буквами используется клавиша Shift, нажатие на которую приводит к смене режима на время ввода одной следующей буквы, и клавиша Caps Lock для постоянной смены режима. Для смены алфавита с русского языка на английский используется клавиша au (клавиша находится между Ctrl и Alt). В начальном состоянии клавиатура находится в режиме строчных русских букв.

Требуется написать программу, выводящую минимальную длину

последовательности прикосновений пера для набора заданной строки.

Технические требования.

Имя входного файла: INPUT.TXT

Имя выходного файла: OUTPUT.TXT

Формат входных данных:

В единственной строке входного файла содержится строка длиной не более 50 скатолов, содержащая заглавные и строчные русские и английские буквы. Формат выходных данных:

В единственной строке выходного файла содержится единственное число - минимальная длина последовательности прикосновений пера для набора заданной строки.

Примеры файлов входных данных: Примеры файлов выходных данных:

Строка 7

ПРИВЕТhеllо 14

Прошу вас помогите!Нужно написать программу,но только обязательно в Visual Basic!!!!!

На вход программе подаются сведения о
телефонах всех сотрудников некоторого учреждения. В первой строке
сообщается количество сотрудников N, каждая из следующих N строк имеет
следующий формат:

<Фамилия> <Инициалы> <телефон>

где <Фамилия> – строка, состоящая не более чем из 20 символов, <Инициалы> - строка, состоящая не более чем из 4-х символов (буква, точка, буква, точка), <телефон> – семизначный номер, 3-я и 4, я, а также 5-я и 6-я цифры которого разделены символом «–». <Фамилия> и <Инициалы>, а также <Инициалы <телефон> разделены одним пробелом. Пример входной строки:

Иванов П.С. 555-66-77

Сотрудники
одного подразделения имеют один и тот же номер телефона. Номера
телефонов в учреждении отличаются только двумя последними цифрами.
Требуется написать как можно более эффективную программу, которая будет
выводить на экран информацию, сколько в среднем сотрудников работает в
одном подразделении данного учреждения.




Вы находитесь на странице вопроса "Дана строка, содержащая не более двадцати латинских букв. Все вхождение «max» в ней заменить на «min» и «макс» на «мин». Подсчитать число таких замен", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.