Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

дана строка символов , состоящих из маленьких латинских букв . Определить сколько каждого вида символов содержится в данной строке. Pascal ABC

10-11 класс

Irinatsienieva 12 сент. 2014 г., 21:24:54 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pozitiff4ik88
12 сент. 2014 г., 22:23:00 (9 лет назад)

const  l:array[1..26] of char = ('a','b','c','d','e','h','i','j','k','l','m','n','o','p','q','r','f','s','t','u','v','w','x','i','y','z');
Var
s:string;
j,i,k:integer;
a:array [1..100] of integer;
begin
readln(s);
k:=0;
For i:=1 to length(s) do
for j := 1 to 26 do
If s[i] = l[j] then
begin
a[j]:=a[j]+1;
end;
for i:=1 to 26 do begin
if a[i]<>0 then
writeln(l[i], ' = ', a[i]);
end;
end.

+ 0 -
MrsHappynes
12 сент. 2014 г., 23:13:29 (9 лет назад)

ща всё будет

+ 0 -
Ordndndn
12 сент. 2014 г., 23:57:27 (9 лет назад)

получается?

+ 0 -
Missolgaoi201
13 сент. 2014 г., 1:42:59 (9 лет назад)

да

+ 0 -
0957651069
13 сент. 2014 г., 4:37:42 (9 лет назад)

осталось только вывести

+ 0 -
Aposohova
13 сент. 2014 г., 5:44:34 (9 лет назад)

ок. жду

Ответить

Другие вопросы из категории

Pascal.

Составьте программу замены местами в массиве B(N) первого положительного и минимального элементов. Спасибо заранее

Вася уехал на отпуск в Японию. По возвращению он понял что забыл пароль от архива.

Но он точно помнит что пароль состоит и 4 символов. Так же он помнит что в пароле присутсвуют цифры от 1 до 9 и буквы латинского алфавита от A до Z. У Васи есть программа для подстановки, но ей нужны база паролей.Помогите Васе написать программу, для базы паролей

Решите кроссворд.

Единица измерения количества информации.(3 буквы)
Одна из тригонометрических функций.(5 букв)
Один из первых языков программирования высокого уровня(7 букв)
Операнд операции сложения.( 9 букв)
Язык программирования (7 букв)
Совокупность точек графического изображения на этапе монитора.(5 букв)
Жаргонное название микросхемы.(3 буквы)

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

Для передачи секретного сообщения используется код состоящий из заглавных латинских букв и цифр. При этом все символы кодируются одним и тем же

количеством бит. Определите информационный объём сообщения длинной в 180 символов.

56) В некоторой стране автомобильный номер состоит из 8 символов. Первый символ – одна из 26 латинских букв, остальные семь – десятичные цифры. Пр

имер номера – A1234567. Каждый символ кодируется минимально возможным количеством бит, а каждый номер – одинаковым и минимально возможным количеством байт. Определите объем памяти, необходимый для хранения 30 автомобильных номеров

В некоторой стране автомобильный номер состоит

из 8 символов. Первый символ – одна из 26 латинских букв, остальные семь –
десятичные цифры. Пример номера – A1234567. Каждый символ кодируется минимально возможным
количеством бит, а каждый номер – одинаковым и минимально возможным количеством
байт. Определите объем памяти, необходимый для хранения 30 автомобильных
номеров.



Вы находитесь на странице вопроса "дана строка символов , состоящих из маленьких латинских букв . Определить сколько каждого вида символов содержится в данной строке. Pascal ABC", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.