Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Строки в Си Задан текст, состоящий из заглавных латинских букв и цифр. Определите, сколько раз каждая гласная буква встречается в тексте. Результат

10-11 класс

распечатайте в виде: Буква – количество. (гласные: A, E, I, O, U)

Marusya2005m 18 сент. 2013 г., 14:26:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
КаТенюшечка
18 сент. 2013 г., 16:31:51 (10 лет назад)

#include <stdio.h>

int main()
{
char c;
int A = 0, E = 0, I = 0, O = 0, U = 0;

while ((c = getchar ()) != '\n')
switch (c) {
case 'A' : {A++; continue;} ;
case 'E' : {E++; continue;} ;
case 'I' : {I++; continue;} ;
case 'O' : {O++; continue;} ;
case 'U' : U++;
}

printf ("A - %d\nE - %d\nI - %d\nO - %d\nU - %d\n", A, E, I, O, U);

getchar ();

return 0;
}

Ответить

Другие вопросы из категории

Для каждого числа от 1 до n определить,

является ли оно простым.
C++

Помогите пожалуйста. Нужно решить через программу Pascal ABC

Определить объем цилиндра и площадь его полной поверхности, если известны радиус основания и высота цилиндра.

Формулы:

Составить программу на паскаль.

Слова могут содержать любые символы языка.

Ребята,срочно помогите!)Даю 100 баллов.Составить алгоритм решения задачи на языке C++ . В отчете предоставить три программы с разными операторами

цикла (do ...while, while, for). В алгоритме и программе массивов не использовать.

Я здесь набросал все ,что мог, помогите доработать, написать до конца все эти операторы в одну программу,не получается.

#include <iostream>
#include <cstdlib>
#include <conio.h>
#include <math.h>

using namespace std;
int main()
{
float a,z,xn,xk,dx,R,max,min; float count=0,x;
a = 2.94;xn = 1.5;xk = 5.5;dx = 0.4;
while (xn <= xk)

for (x >= xn; x <= xk; x+=dx, dx = dx + 0.4)
{
do
{
z = a*pow((a*x*x*x*x*x*x*x/cos(a*a*a)+1,31),(1/5));
printf("X = %10f, Z = %10f \n", x, z);
dx = dx + 0.4;
}
while (x <= xk);
return 0;
}
{
max = x;min = z;
if (x > max) max = x;
if (z < max) min = z;
if (count > 2) count = 0;
if (count == 2) printf("X = %10f, Z = %10f \n", x, z);
count=0;
}
cout<<"max="<<max<<"\t min="<<min<<"\n";
cout<<"R="<<min-max<<"\n";
system("PAUSE");
return 0;
}

Читайте также

Два текста на русском языке записаны в различных кодировках. Первый текст состоит из 240 символов и записан в 16-битной кодировке Unicode, второй текст сос

тоит из 120 символов и записан в 8-битной кодировке КОИ-8. Во сколько раз количество информации в первом тексте больше, чем во втором?
1)5 2)2 3)3 4)4

Для передачи секретного сообщения используется код состоящий из заглавных латинских букв и цифр. При этом все символы кодируются одним и тем же

количеством бит. Определите информационный объём сообщения длинной в 180 символов.

Вывести все правильные скобочные выражения длиной N, состоящие из круглых и квадратных скобок.

Ввод
В первой строке находится единственное число N.
Вывод
Каждое выражение выводится в отдельной строке.
Ограничения
1 ≤ N ≤ 14, N - четное.
Вывести все правильные скобочные выражения длиной N, состоящие из круглых и квадратных скобок.
Ввод
В первой строке находится единственное число N.
Вывод
Каждое выражение выводится в отдельной строке.
Ограничения
1 ≤ N ≤ 14, N - четное.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.



Вы находитесь на странице вопроса "Строки в Си Задан текст, состоящий из заглавных латинских букв и цифр. Определите, сколько раз каждая гласная буква встречается в тексте. Результат", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.