Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите набрать в паскале:

5-9 класс

какое значение будет иметь переменная z после выполнения операторов:
z:=0;
if x>0 then if y>0 then z:=1 else z:=2;
при следующих значениях переменных x и y:
а) x=y=1;
b) x=1, y=-1;
c) x=-1, y=1

77777777775 02 июня 2013 г., 2:22:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natalikostryuk
02 июня 2013 г., 4:12:35 (10 лет назад)

Ответ:
a) z:=1
b) z:=2
c) z:=0

Ответить

Другие вопросы из категории

1.Какие из чисел 443₈ ,101010₂ ,256 ₁₀ можно сохранить в 8-разрядном формате?

2.Запишите следующие числа в естественной форме:
а.0,3800456 × 10²
б.0,245 × 10⁻³
в.1,256900Е+5
г.9,569120Е-3
3.Запишите число 2010,0102₁₀ пятью различными спосабами в экспоненциальной форме.

Определите, что получится в результате выполнения в графическом редакторе Paint следующей последовательности действий. Действия: 1.

Установить основной цвет жёлтый. 2.

Выбрать инструмент Овал и настроить его на 3-ий режим заполнения.

3. Удерживая клавишу {Shift}, нарисовать круг.

4. Выбрать инструмент Линия и настроить его нарисование самых жирных линий. 5. Удерживая клавишу {Shift), изобразить отрезки, выходящие из центра жёлтого круга.

На экране будет нарисовано солнце.

Предложите другую последовательность изображения этого же объекта: (Помогите другую последовательность сделать!).

Какое число будет напечатано на экране компьютера в результате выполнения фрагмента программы?

Бейсик
a=5 : b=8
If b/2>=a-1 Then
a=b+5
b=b*2-a
Else
a=a*b
b=b-a
Endif
Print b

Паскаль
a:=5 ; b:=8 ;
If b/2>=a-1 Then
begin
a:=b+5;
b:=b*2-a;
end
Else
begin
a:=a*b;
b:=b-a;
end;
Writeln(b);

Читайте также

Помогите, с помощью паскаля надо сделать следующее:

Составить программу, решающую следующую задачу: дано трехзначное число. В нем зачеркнули первую цифру слева и приписали ее справа. Вывести полученное число.
Так же:
Составить программу, решающую следующую задачу: дан номер некоторого года (целое положительное число). Определить соотв-щий ему номер столетия, учитывая, что, к примеру, началом 20го столетия был 1901 год. Сам то я знаю как решать, но не смогу записать это в паскаль!

ПОМОГИТЕ!!!удалить элемент линейного массива вещественных чисел, которые меньше среднего арифметического элемента массива.если таких элементов несколько ,

удалить последний из найденных.Помогите решить в паскале.(вычислить средн.ариф.номер э-та,....)

Помогите, пожалуйста, по Паскалю! 21. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе - произведение.

После этого компьютер должен напечатать текст ЗАДАЧА РЕШЕНА.

22. В компьютер вводятся длины трех отрезков. Компьютер должен ответить на вопрос, правда ли, что пер-вый отрезок не слишком длинен, чтобы образовать с другими двумя отрезками треугольник. Указание: Для этого его длина должна быть меньше суммы длин двух других отрезков. Замечание: Пока не думайте о том, что слишком длинными могут быть второй или третий отрезки. Об этом – задание из 5.5.

помогите изобразить в паскале такой рисунок:

^^
////0\\
\\\\\\\\\
############
############
# #
_ _

Помогите отредактировать программу - Паскаль. Где-то ошибка.

Необходимо удалить первый кратный 3 элемент массива.
program udalenie;
var i,n,k:integer;
a:array[1..1000] of integer;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
while i<=n do
if a[i] mod 3=0 then
begin
for i:=k to n-1 do
a[i]:=a[i+1];
n:=n-1; exit;
end;
for i:=1 to n do write(a[i],' ');
close (input);
close (output);
end.



Вы находитесь на странице вопроса "Помогите набрать в паскале:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.