Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите, пожалуйста, по Паскалю! 21. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе - произведение.

5-9 класс

После этого компьютер должен напечатать текст ЗАДАЧА РЕШЕНА.

22. В компьютер вводятся длины трех отрезков. Компьютер должен ответить на вопрос, правда ли, что пер-вый отрезок не слишком длинен, чтобы образовать с другими двумя отрезками треугольник. Указание: Для этого его длина должна быть меньше суммы длин двух других отрезков. Замечание: Пока не думайте о том, что слишком длинными могут быть второй или третий отрезки. Об этом – задание из 5.5.

Kangggggggggggg23 05 июня 2013 г., 3:34:11 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Krytayaledi
05 июня 2013 г., 4:15:59 (10 лет назад)

Program Pr1;
uses crt;
var a,b,c:integer;
Begin
writeln('a,b');
readln(a,b);
if a>b then c:=a+b
else c:=a*b;
writeln('Задача Решена');
end.

2)

Program Pr1;
uses crt;
var a,b,c:integer;
Begin
writeln('a,b,c');
readln(a,b,c);
if a<b+c then writeln('не длинный')
else writeln('Длинный');
end.

+ 0 -
ильмано
05 июня 2013 г., 5:05:34 (10 лет назад)

Вот более короткое:

var a,b:real;

begin

readln(a,b);

if a>b then writeln(a+b) else writeln(a*b);

writeln('Задача решена');

end.

 

var a,b,c:integer;

begin

readln(a,b,c);

if a<(b+c) then writeln('Не слишком длинный') else writeln('Перебор');

end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ ПОЖАЛУЙСТА!!!!!!!!!!!!

Пользователь,перемещаясь из одного каталога в другой ,последовательно посетил каталоги LESSONS ,CLASS ,SCHOOL ,D : \ , либо спускался в каталог на уровень ниже ,либо поднимался на уровень выше .Какого полное имя каталога ,из которого начал перемещение пользователь?
1) D: \ MYDOC\LETTERS
2) D:\SCHOOL\CLASS\LESSONS
3) D:\LESSONS\CLASS\SCHOOL
4)D:\LESSONS

Читайте также

Ребят, помогите пожалуйста по Паскалю. 1. Написать программу, которая вводит последовательность вещественных чисел, состоящую

из N элементов, и определяет, является ли эта последовательность возрастающей.

2. Дан целочисленный массив размерности N. Необходимо "сжать" массив, выбросив из него каждый второй элемент. Дополнительный массив использовать нельзя.

Вводятся 4 числа. Вывести на экран максимальное

Вводятся три числа. Вывести на экран число с минимальной суммой цифр.

Помогите пожалуйста в Паскале

ПОМОГИТЕ, ПОЖАЛУЙСТА!!!!!!

Даны два действительных числа Х и У. Если Х > У, то вычислить произведение этих чисел, иначе их сумму. Разработать схему алгоритма для решения этой задачи( Нужно решить через Паскаль с ветвящейся структурой).



Вы находитесь на странице вопроса "Помогите, пожалуйста, по Паскалю! 21. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе - произведение.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.