Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дано 100 чисел. Проверить правда ли, что произведение отрицательных чисел не превосходят 100 по модулю. Решить в паскале, помогите пожалуйста)

5-9 класс

Kryu1974 23 июня 2016 г., 4:00:48 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zairamaksymova
23 июня 2016 г., 5:08:47 (7 лет назад)

var
  a: array [1..100] of integer;
  i: integer;
  b: Int64 := 1;

begin 
  for i := 1 to 100 do
  begin
    a[i] := random(-2, 20);
    write(a[i], ' ');
  end;
  writeln();
  for i := 1 to 100 do
  begin
    b *= (a[i] < 0 ? abs(a[i]) : 1);
  end;
  writeln(b <= 100, '(', b, ')');
end.

Ответить

Читайте также

Помогите, пожалуйста, по Паскалю! 21. В компьютер вводятся два числа. Если первое больше второго, то вычислить их сумму, иначе - произведение.

После этого компьютер должен напечатать текст ЗАДАЧА РЕШЕНА.

22. В компьютер вводятся длины трех отрезков. Компьютер должен ответить на вопрос, правда ли, что пер-вый отрезок не слишком длинен, чтобы образовать с другими двумя отрезками треугольник. Указание: Для этого его длина должна быть меньше суммы длин двух других отрезков. Замечание: Пока не думайте о том, что слишком длинными могут быть второй или третий отрезки. Об этом – задание из 5.5.

В торговом центре этажи нумеруются так: …, –3, –2, –1, 1, 2, 3, … (то есть нет нулевогоэтажа). Вася спустился на лифте с этажа с номером A на B этажей, а

затем поднялся на лифтена C этажей. Определите, на каком этаже он оказался.Программа получает на вход три целых числа: в первой строке записано число A, вовторой — B, в третьей — С. Число A не равно нулю и не превосходит по модулю 100, числа Bи С — положительные и не превосходят 100. Программа должна вывести одно целое число — номер этажа, на котором оказался Вася

ПОЖАЛУЙСТА!ПОМОГИТЕ!СРОЧНО!

Решить задачи на турбопаскале:
1.Дано натуральное число Найти сумму и произведение первых двух чисел.
2.Дано n-значное натуральное число. Правда ли что квадрат произведения цифр числа равняется кубу суммы цифр числа.
3.Составить программу, которая печатает таблицу умножения и сложения натуральных чисел в десятичной системе счисления.

Ответьте на вопросы:Верно ли, что алгоритм – это план решения задачи? _______________________________Верно ли, что дрессированные животные могут быть

исполнителями алгоритмов?_____Верно ли, что исполнитель может выполнять только те команды, которые входят в его СКИ?_________________________Верно ли, что процесс мытья 10 тарелок является циклическим алгоритмом?__________Верно ли, что фигура ромб означает начало и конец алгоритма в блок-схеме?__________

Правда ли, что строка в редакторе Блокнот может быть бесконечной длины? а)да,это не зависит от размеров окна б)нет, ее длина зависит от ко

дировки символов

в)да, если не включить опцию"переносить по словам"

г)нет,она всегда заканчивается у границы окна



Вы находитесь на странице вопроса "дано 100 чисел. Проверить правда ли, что произведение отрицательных чисел не превосходят 100 по модулю. Решить в паскале, помогите пожалуйста)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.