Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Пользователь вводит с клавиатуры несколько

5-9 класс

английских слов (количество определите сами). Написать программу, которая выдает
список этих слов, упорядоченных по алфавиту (для упрощения задачи считайте, что
все слова начинаются с разной буквы). Паскаль

Milaya0021 22 марта 2014 г., 22:24:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Agustina
23 марта 2014 г., 1:13:27 (10 лет назад)

Var a:array[1..100] of string;
n:string;
i,m,j:integer;
begin
writeln ('Введи кол-во слов');
readln(m);
for i:=1 to m do
 begin
 readln (n);
 a[i]:=n;
 end;
for j:=1 to m do
for i:=1 to m-1 do
if a[i]>a[i+1] then
begin
n:=a[i];
a[i]:=a[i+1];
a[i+1]:=n;
end;
writeln;
for i:=1 to m do
writeln (a[i]);
end.

Ответить

Читайте также

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.

"сколько лет бабушке?"Компьютер загадывает целое число от 1 до 100. Пользователь вводит с клавиатуры некоторое число и получает один из ответов:"Мое

чило меньше","Мое число больше","Вы угадали".процесс повторяется до тех пор пока не будет угадано число.

помогите на паскале сделать



Вы находитесь на странице вопроса "Пользователь вводит с клавиатуры несколько", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.