Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

номер семнадцать лчень нужно на паскале

10-11 класс

L12 26 сент. 2013 г., 0:06:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anka1804
26 сент. 2013 г., 2:04:52 (10 лет назад)

var x, y, i: Real;
begin
     i := 1;
     write('x: ');
     while (i <= 2.1) do
     begin
          write(i:4:2, '  ');
          i := i + 0.1;
     end;
     i := 1;
     writeln();
     write('y: ');
     while (i <= 2.1) do
     begin
          write(sin(i/2)/cos(i/2) + 2 * cos(i):4:2, '  ');
          i := i + 0.1;
     end;
     writeln();
end.

Вот так, только числа округляются, чтобы влазили:)

Ответить

Другие вопросы из категории

Помогите решить задачку (Паскаль) Дана матрица B(4,4) 1) Найти произведение положительных элементов среди элеметов

рассположенных выше побочной диагонали матрицы B.

2) Найти минимальный элемент во втором столбце матрицы B.

3) Поменять местами найденный минимальный эелемент и значение третьего элемента в четвертой строке.

Читайте также

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!

Помогите решить задачу на паскале, очень нужно:

Дана строка, удалить текст находящийся в скобках (вместе со скобками)

Я тут начал делать, вот только с удалением у меня ничего не получается, напишите как можно сделать

Вот как я делал:
program zd;
uses crt;
var s:string; i,l,n,t,y:integer;
begin
clrscr;
writeln('Введите строку');
readln(s);
l:=length(s);
for i:=1 to n do begin
if s[i]='(' then
t:=i; {здесь присваивал номер найденной скобки}
if s[i]=')' then
y:=i; {так же, как и выше}
delete (s,t,i); {у меня получается, что он удаляет с открывающей скобки и всё что находится вправо, а левая часть до скобки остается нетронутой}
end;
writeln('Данный результат =', s);
readln;
end.

Петя любит есть вареные яйца.Для того, чтобы приготовить яйцо в смятку нужно варить его Х минут. Чтобы приготовить яйцо вкрутую, нужно сначала приготовить

его всмятку, а потом варить его У минут. Петя любит есть яйцо, когда оно наполовину приготовлено вкрутую, т.е.когда яйцо сначала приготовлено всмятку, а потом прошла еще половина времени, необходимого для того, чтобы это яйцо стало приготовленым вкрутую. Найдите, сколько минут Пете нужно варить яйцо. (1менше или равна Х, У меньше или равен 10 в восемнадцатой степени) Написать программу на Паскаль

Пожалуста!!!!!!!!!!!!!!!!!!!!!!ОЧ срочно!!!!!! Написать программу на паскале, которая вводит

массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов:

а) 3 5 -2 0 -6 -8 1

б) -1 -2 -3 0 -1 2 3

массивы должны вводися вручную а не рандомно.



Вы находитесь на странице вопроса "номер семнадцать лчень нужно на паскале", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.