Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дан массив положительных и отрицательных чисел. Вывести количество положительных и отрицательных чисел, стоящих на нечетных местах. Срочно!!!

5-9 класс

Lilitsan 23 мая 2013 г., 12:45:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
IvanYandukin0
23 мая 2013 г., 14:21:24 (10 лет назад)

var
  k, sum, n, i: integer;
  A: array of integer;
begin
  writeln('Введите размерность массива: ');
  readln(n);
  SetLength(A, n + 1);
  writeln('Введите ', n, ' элементов массива :');
  for i := 1 to n do
  begin
    readln(A[i]);
    if i mod 2 <> 0 then
    begin
      if A[i] > 0 then inc(sum);
      if A[i] < 0 then inc(k);
    end;
  end;
  writeln('Кол-во положительных чисел, стоящих на нечетных местах: ', sum);
  writeln('Кол-во отрицательных чисел, стоящих на нечетных местах: ', k);
end.

+ 0 -
Kirillposk
23 мая 2013 г., 17:05:30 (10 лет назад)

uses crt;
const Z=5;
var a:array [1..Z] of real;
    x,k,n:integer;
begin
     for x:=1 to Z do
     begin
          readln(a[x]);
          if (x mod 2=1) and (a[x]>0) then inc(k);
          if (x mod 2=1) and (a[x]<0) then inc(n);
     end;
     writeln('Положительных: ',k);
     writeln('Отрицательных: ',n);
end.

Ответить

Читайте также

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

cформировать одномерный массив из 15 элементов с помощью случайных чисел, получить новый массив каждый элемент, которого равен кубу соответствующего

элемента исходного массива, в полученном массиве вывести элементы стоящие на нечетных местах. Напишите, пожалуйста программу на языке Pascal

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

1). Дан миссив из n целых чисел. Напишите программу определяющую сколько в массиве четных чисел, 2). Дан массив из n целых чисел. Напишите

программу определяющую каких элементов в точке больше положительных или отрицательных



Вы находитесь на странице вопроса "дан массив положительных и отрицательных чисел. Вывести количество положительных и отрицательных чисел, стоящих на нечетных местах. Срочно!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.