Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Срочно! Написать программу на Pascal ABC. Массивы.

10-11 класс

См. приложенные скрины.

Samuray2000 21 нояб. 2014 г., 11:20:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ramiro
21 нояб. 2014 г., 11:52:27 (9 лет назад)

uses crt;
var a:array[1..99,1..99] of integer;
i,j,min,n:integer;
sr:real;
begin
n:=5;
sr:=0;
writeln('Исходный массив:');
for i:=1 to n do begin
for j:=1 to n do begin
a[i,j]:=random(99-1+1)+1;
write(a[i,j]:3);
sr:=sr+a[i,j];
end;
writeln;
end;
sr:=sr/(n*n);
writeln('Среднее арифметическое всех элементов равно ',sr);
min:=99;
for i:=1 to n do begin
for j:=1 to n do begin
if a[i,j]>sr then begin
if a[i,j]<min then min:=a[i,j]; end;
end;
end;
writeln('Минимальное число, большее среднего арифметического, равно ',min);
end.

Это первая задача, матрица сделана квадратной и размером 5х5, значения элементов задаются случайно от 1 до 99. Размер матрицы задан переменной n для того, чтобы было быстрее исправить, если размер матрицы надо вводить. 

Вторая задача написана очень странно и мною не понята :)

Ответить

Другие вопросы из категории

ПОЖАЛУЙСТА ПОМОГИТЕ РЕШИТЬ!!! Желательно с решением... Восемь школьников, оставшихся в классе на перемене, были вызваны к директору. Один из них

разбил окно в кабинете. На вопрос директора, кто это сделал, были получены ответы: Егор: «Разбил Андрей!». Света: «Вика разбила». Оля: «Разбила Света». Миша: «Это кто-то с улицы!». Надя: «Да, Оля права…». Коля: «Это либо Вика, либо Света!». Андрей: «Ни Вика, ни Света этого не делали». Вика: «Андрей не бил!». Кто разбил окно, если известно, что из этих восьми высказываний истинно ровно три?

сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен удвоенному числу, введенному с клавиатуры;
2-й равен квадрату предыдущего индекса;
3-й равен остатку от деления индекса на 2

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Написать программу на Pascal ABC.Дан целочисленный массив размера N. Вычислить сумму и количество положительных элементов,

произведение и количество отрицательных элементов, произведение элементов до
первого отрицательного. Отсортировать массив по возрастанию.

Написать программу в Pascal, используя массивы.

Дано массив А[1..n]. Сделать программу которая выводит те элементы массива? индексы которых являются степени двойки
Желательно с обьяснением строк

Написать программу на паскале: Дана матрица А, имеющая N строк и N столбцов.

Сформируйте два одномерных массива. В один перешлите четные, а в другой
-нечетные элементы матрицы. Выведите на экран все массивы.



Вы находитесь на странице вопроса "Срочно! Написать программу на Pascal ABC. Массивы.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.