Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны скорости 7 гоночных марок машин. Определить две марки у которых скорость наибольшая.

10-11 класс

в паскале ребят=***********

Артём543 04 марта 2017 г., 0:24:12 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
5665498
04 марта 2017 г., 2:37:50 (7 лет назад)

var
a,max,max2:real;
i:integer;
begin
  writeln('Введите скорость');
    for i:=1 to 7 do
        begin
            readln(a);
              if a>max then

              if max>max2 then

                 max2:=a

              else

                 max:=a;

         end;

     writeln(max:4:2,' ',max2:4:2);

end.

           или через массив

В массив заносим 2 элемента. В цикле вводим остальные элементы. В массиве находим минимальный и, если введенный следующий элемент (b) больше минимального массива, то записываем b в массив на место наименьшего.

В результате в массиве два максимальных эл-та

 

var

a:array[1..2]of integer;

+ 0 -
Marisabelis07
04 марта 2017 г., 3:37:16 (7 лет назад)

через массив можно?

+ 0 -
N994os
04 марта 2017 г., 6:10:20 (7 лет назад)

да

Ответить

Другие вопросы из категории

По каналу связи передаются сообщения, содержащие только 4 буквы А, И, С, Т. Для кодирования букв А, И, С используются 5-битовые кодовые слова: А -

10000, И - 11110, С - 01011. Для этих кодовых слов выполнено такое свойство: кодовые слова для разных букв отличаются не менее, чем в трех позициях. Это свойство важно для расшифровки сообщений при наличии помех.
Для буквы Т нужно выбрать кодовое слово так, чтобы оно тоже отличалось от кодовых слов для букв А, И, С не менее, чем в трех позициях.
Какое из перечисленных ниже кодовых слов можно использовать для буквы Т?

Варианты ответа:


1)585
2)513
3)65

///Непонятно,что с такими числами делать,которые в варианте ответа указаны.В какую-то систему счисления их перевести?

ПОМОГИТЕ СРОЧНО ПОЖАЛУЙСТА . Задача:

Сформировать массив из 10 произвольных чисел. Определить сумму положительных, произведение отрицательных и количество нулевых элементов этого массива.
Pascal ABC.

Расположить в порядке возрастания значения арифметических выражений:

#*- система счисления (#2- двоичная, #8- восьмеричная, #16- шестнадцатеричная и т.д.)

1) CXXVIII + 10001#2 (#2- двоичная сис-ма счисления)
2)206#10 - C9#16
3)MIV - 143#8
4) 238#16 + 100000#2
5)400#16 - CCLVI
6) 3764#8 + 12#10

Ответ прошу предоставить с решением.

Читайте также

На день рождения Карлсона Малыш принёс в подарок большой пакет с конфетами. Малыш понимал, что никакой справедливости при разделе конфет от Карлсона

ожидать не стоит. Поэтому он придумал игру, в которой ему обязательно должна достаться последняя конфета, а если повезёт, то и больше.Правила игры очень просты. Карлсон из общего пакета выделяет K конфет (K никак не меньше 3, но и, пожалуй, не больше 100000000). Играющие по очереди берут конфеты из кучки, причём за один ход каждый из них может взять от 1 до L конфет. Понятно, что первым ходить будет Карлсон, но он благородно уступил Малышу право определить максимальное число конфет L (2<=L<K), которое может взять игрок за один ход (в течение игры L не меняется). Малыш будет в выигрыше, если ему удатся взять последнюю конфету. Необходимо написать программу, которая помогла бы Малышу делать свой выбор числа L таким образом. чтобы последняя конфета всегда доставалась ему. Другими словами, по заданному числу конфет в кучке K необходимо определить такое число L, которое гарантирует Малышу хоть одну конфету. Так, например, если в кучке всего три конфеты, то победу Малышу обеспечивает выбор L=2. В самом деле, если Карлсон своим ходом заберёт одну конфету, то Малыш, взяв обе оставшихся конфеты, выиграет и, напротив, если Карлсон возьмёт две конфеты, что более вероятно, то Малышу достанется последняя конфета.Входные данные: Вход для этой задачи состоит из одной строки, в которой записано единственное число K - количество конфет в кучке, выбранное Карлсоном.Выходные данные: На выход следует записать единственное число L - максимальное число конфет, которое можно взять за один ход - обеспечивающее победу Малышу. Если таких чисел несколько, то следует вывести наименьшее из них. если таких чисел нет, то следует вывести число 0.Для проверки:Вход: 3; Выход: 2Вход: 7; Выход: 6Язык программирования: Pascal

1)Определите длительность звукового файла, который уместится на дискете 3,5"

при высоком качестве звука (16 бит, 48 кГц).Учтите, что для хранения данных на такой дискете выделяется 2847 секторов объёмом 512 байт каждый (ход решения)

2)Вычислить информационный объём текстового документа в Мбайт( с точность до сотых)
и узнать,сколько дискет 3,5 дюйма объёмом 1,44 мб понадобится для переноса англо-русского словаря,который содержит 604 страницы ( 89 символов в строке, 66 строк на странице) (ход решения)

Вы работаете с твердотельным накопителем SSD «Sata III SSD720 6Gb/s – 512 GB (made in Taiwan)». Одно из последующих утверждений является неверным.

Выберите ответ:
Устройство произведено в Тайване
Объем памяти устройства равен 512 GB
Скорость вращения дисков в устройстве равна 7200 оборотов в минуту
Скорость передачи данных у этого устройства достигает 6 Gb/s
Устройство является жестким диском с интерфейсом SATA



Вы находитесь на странице вопроса "Даны скорости 7 гоночных марок машин. Определить две марки у которых скорость наибольшая.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.