Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан файл целых чисел, содержащий четное количество элементов. Удалить из данного файла вторую половину элементов.

10-11 класс

Katherinepierc 26 дек. 2013 г., 8:36:25 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Suldus91
26 дек. 2013 г., 11:26:16 (10 лет назад)

var f:file of integer;   
 a,i,k,n:integer;
begin
randomize;
assign(f,'file');
rewrite(f);
repeat
write('Четное количество элементов: ');
readln(n);
until(n>1) and (n mod 2=0);
for i:=1 to n do
 begin 
 a:=random(100); 
 write(f,a); 
end;
writeln('Содержание исходного файла:');
reset(f);
while not eof(f) do
 begin 
 read(f,a); 
write(a,' ');
 end;
close(f);
writeln;
reset(f);
seek(f,filesize(f)div 2);
truncate(f);
writeln('Содержание измененного файла:');
reset(f);
while not eof(f) do
 begin
  read(f,a); 
 write(a,' '); 
end;
close(f);
readln
end.

Ответить

Другие вопросы из категории

Какое значение будет выведено в результате исполнения алгоритма ?

Нач
к:=2; к1:=1; с:=59
Нц для I от 50 до 164
С:=с+к*I; k:=k+k1; k1:=-k1
Кц
Выаод с
Кон
Ответы 1) 30762 2) 30764 3) 30766 4) 30768 5) 30770

4^2013+2^2012-15

Сколько единиц в двоичной записи результата

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

Help!!! Дан массив целых чисел, состоящий из 10 элементов.Заполнить его с клавиатуры. Найти:

-Удвоенную сумму положительных элементов;

-Удалить все четные элементы массива.

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

дан массив целых чисел (n=10), заполненный случайными числами из промежутка [-40,30]. 1. удалить из него все элементы, которые состоят из одинаковых

цифр(включая однозначные числа). 2. вставить число k перед всеми элементами, в которых есть цифра 1(k вводить с клавиатуры). 3. переставить первые три и последние три элемента местами, сохраняя их следование.

Дан массив целых чисел из 15 элементов, заполненный случайным образом числами из промежутка [ -20, 50 ].

Удалить из него все элементы, в записи которых есть цифра 5.
Вставить число k после всех элементов, кратных своему номеру (k вводится с клавиатуры).
Поменять местами первый положительный и последний отрицательный элементы.



Вы находитесь на странице вопроса "Дан файл целых чисел, содержащий четное количество элементов. Удалить из данного файла вторую половину элементов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.