Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

си ++ одномерные массивы 18номер

10-11 класс

W12002 26 июня 2014 г., 9:20:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
пинок
26 июня 2014 г., 11:19:09 (9 лет назад)

int someArray[SIZE];

for (int i = 0; i < SIZE; ++i)
{
      if (someArray[i] % 2 == 0)
      {
             someArray[i] *= 2; 
      }
      else
      {
              someArray[i] /= 2; 
      }
}

+ 0 -
незнайка124
26 июня 2014 г., 12:10:48 (9 лет назад)

#include "iostream.h"

main()
{
  int m[10];
  int i, cA = 0, cB = 0, sA = 0, sB = 0;

  for(i = 0; i < 10; i++)
    m[i] << cin;

  for(i = 0; i < 10; i++)
  {
    if (m[i] >= 0)
    {
      cA++;
      sA = sA + m[i]; 
    }
    else
    {
      cB++;
      sB = sB + m[i];
    }
  }

  printf("\nСредн.арифм. положительных чисел = %f", sA / cA);
  printf("\nСредн.арифм. отриц. чисел = %f", sB / cB);

  return 0;
}

Ответить

Другие вопросы из категории

13. Если отрицание стоит над операцией, то первым выполняется:

1). отрицание, затем операция

2). операция затем отрицание

3). операция над переменой

Читайте также

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива. Заполнение массива элементами

организовать путем ввода с клавиатуры. В одномерном массиве из N натуральных чисел вычислить сумму удвоенных четных чисел.

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

1.В произвольно заданном одномерном массиве ( случайные значения из отрезка -6 до 11 ) из 6 элементов, определить количество отрицательных, нулевых и

положитльных элементов.
2.
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию



Вы находитесь на странице вопроса "си ++ одномерные массивы 18номер", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.