Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

с помощью алгоритма Евклида найти НОД чисел 108 и 360

5-9 класс

Magicle 01 нояб. 2014 г., 14:06:51 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mashkaaaaaaaaaaa
01 нояб. 2014 г., 16:35:58 (9 лет назад)

НОД будет  36.
Внизу прикрепил скриншот с алгоритмом Евклида. Если нужно, могу написать код программы или сразу готовую программу могу сбросить)

Ответить

Другие вопросы из категории

Название операционной системы для мобильных систем, совпадающее с названием человекоподобного робота, - это...

А) R2D2, Б) киборг, В) android, Г) T1000.

помогите пожалуйста,сегодня нужно

Изначально

растровое изображение имело палитру 2 цвета. В процессе его преобразования
информационный объём увеличился в 8 раз. Сколько цветов стало в палитре?
ПОМОГИТЕ ПОЖАЛУЙСТА!КАК ПРАВИЛЬНО ОФОРМИТЬ И РЕШИТЬ?

Читайте также

Граждане информатики, прошу помощи. Pascal ABC.

Что не так в коде? Надо найти НОК трёх чисел через алгоритм Евклида.
Тест: числа 4,6,18, ответ 36.

Код:

Program No4;
var a,b,c:integer;

{----------АЛГОРИТМ ЕВКЛИДА----------}
function evc (a,b:integer):integer;
var m,m1,m2,z:integer;
begin
z:=0;
//определение большего числа
if a=b then evc:=a else
begin
if a>b then

begin
///m1 - большее число из двух, m2 - меньшее.
m1:=a;
m2:=b;
end

else

begin
m1:=b;
m2:=a;
end;
//определение большего числа - готово
repeat
m:=m1 mod m2; ///Большее число делим на меньшее;
if m=0 then z:=m2 ///Если делится - то НОД есть меньшее число;
else begin ///Иначе меняем большее на меньшее,а меньшее - на остаток от деления (по Евклиду).
m1:=m2;
m2:=m;
end
until z<>0;///Повторяем, пока НОД не появится.

evc:=z;
end;
end;
{---------/АЛГОРИТМ ЕВКЛИДА----------}


{----------АЛГОРИТМ НОК----------}
function znam (a, b, c:integer):integer;
var Nabc,Nab:integer;
begin
Nab:=evc (a,b); ///НОД (а.b) - это результат алгоритма Евклида для чисел А и B:
Nabc:=evc (c, Nab); ///НОД (С,Nab) - это результат алгоритма Евклида для чисел С и Nab:
znam:=a*b*c div Nabc; ///НОК = ПРОИЗВ. ЧИСЕЛ / НОД
end;
{----------АЛГОРИТМ НОК----------}

begin
readln (a,b,c);
writeln (znam (a,b,c));
end.

Заранее спасибо.

Выполнить в программе Geany.Паскаль.Пожааалуйста) Задача 1. Вывести на экран последовательность из N чисел (N задаётся пользователем): 5, -10,

15, -20,
25, …
Использовать цикл for и условие в нём.

Задача 2.Найти сумму чисел от 1 до 100, кратных 7. Кратность находим при помощи операции mod

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n

Нужна помощь срочно,в Программе КуМир ,надо решить задачки,и прошу прислать ответы:

1)Найти сумму чисел от 1 до 10
2)Найти сумму чётных чисел от 2 до 30
3)Найти сумму нечётных чисел от 1 до 30
4)Найти произведение чисел от 1 до 10
5)Найти произведение чётных чисел от 10 до 20



Вы находитесь на странице вопроса "с помощью алгоритма Евклида найти НОД чисел 108 и 360", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.