Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите сделать программу pascal. В одномерном массиве с четным количеством элементов (2N) находятся координаты N точек плоскости. Они располагаются в сле

10-11 класс

дующем порядке: x1y1х2, у2, х3, у3, и т. д. Определить кольцо с центром в начале координат, которое содержит все точки.

Makarychevae 14 марта 2015 г., 5:41:09 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Alpok83
14 марта 2015 г., 6:18:47 (9 лет назад)

const
  n = 10;//предельное количество точек

var
  a: array[1..2 * n] of real;
  x, y, l,lmax, lmin: real;
  i, j, k: integer;

begin
  writeln('Введите количество точек (не более ', n, ')');
  readln(k);
  writeln('Вводите координаты точек (x,y) попарно');
  lmax := 0;
  lmin := 1e10;
  for i := 1 to k do
  begin
    j := 2 * i - 1;
    read(a[j], a[j + 1]);
    l := sqr(a[j]) + sqr(a[j + 1]); //квадратами расстояния до точки
    if lmax<l then lmax:=l;
    if lmin>l then lmin:=l
  end;
  writeln;
  writeln('Все точки находятся внутри кольца с радиусами ',sqrt(lmin),', ',sqrt(lmax))
end.

Тестовое решение:

Введите количество точек (не более 10)
5
Вводите координаты точек (x,y) попарно
3 6 2 5 -4 -3 5 7 3 3

Все точки находятся внутри кольца с радиусами 4.24264068711928, 8.60232526704263


Ответить

Другие вопросы из категории

помогите плиз Написать программу для расчета по двум формулам. предварительно подготовтье тестовые примеры с помощью калькулятора. Отсуствующие

в языке функции выразить через имеющиеся. На печать вывести значения исходных данных и результаты вычислений.

х^3*tg^2*((x+b)^2)+a/(корень из (x+b));

(bx^2-a)/(e^ax-1).

3. Даны простые высказывания:

А={Принтер- устройство ввода
информации},

Читайте также

Ребят, помогите! Тема: одномерные массивы. Две задачи:1) Написать прог

Ребят, помогите! Тема: одномерные массивы. Две задачи:

1) Написать программу, которая из заданного одномерного массива размерности N находит сумму только тех элементов, значения которых больше некоторого значения S.
S=5; Массив: 0,4 5,6 -2 10,1


2) При поступлении в ВУЗ абитуриенты, получившие "Двойку" на первом экзамене, ко второму не допускаются. В массиве A[N] записаны оценки экзаменующихся, полученных на первом экзамене. Подсчитать, сколько человек не допущено ко второму экзамену!

Заранее благодарю!

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

язык Pascal ABC. Напишите программу:

Дан двухмерный массив A[1..m,1..n]. Написать программу построения одномерного массива B[1..m], элементы которого соответственно равны суммам элементов строк.

Составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива. Заполнение массива элементами

организовать путем ввода с клавиатуры. В одномерном массиве из N натуральных чисел вычислить сумму удвоенных четных чисел.



Вы находитесь на странице вопроса "Помогите сделать программу pascal. В одномерном массиве с четным количеством элементов (2N) находятся координаты N точек плоскости. Они располагаются в сле", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.