Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте программу для решенияСоставьте программу для решения следующей задачи с использование цикла

5-9 класс

с предусловием: «Выведите все точные квадраты натуральных чисел,
не превосходящие данного числа n».

артемдема 05 янв. 2017 г., 23:30:18 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Сима97
06 янв. 2017 г., 2:26:06 (7 лет назад)

Немного не понял..

#include <iostream>
using namespace std;
int main()
{
int n;
cin>>n;
for (int i=1;i<=n;i++)
{
cout<<sqrt(double(i))<<endl;
}
}

+ 0 -
Ninanenina38
06 янв. 2017 г., 3:50:33 (7 лет назад)

var n,i:integer;
begin
read (n);
for i:=1 to n do
if sqr(i)<=n then writeln (sqr(i));
end.

Ответить

Читайте также

1. Составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из Лондона в Нью-Йорк, если в самолете три

четверти пассажиров имеют билеты первого класса, стоимостью Х рублей за каждый. Остальные пассажиры имеют билеты второго класса, которые дешевле на 20%
2.Составьте программу определения стоимости набора конфет, в которой находятся следущие сорта:
Наименование: Количество: Цена,руб:
Красная шапочка 500 г k
Алые паруса 200 г a
Воронежские 100 г b
Чародейка 250 г m

Очень срочно, и очень нужно составить программы по информатике PASCAL ABC, помогите, пожалуйста от этих программ зависит моя четвертная.

1. Составьте программу для определения большего из двух чисел х или у
2. Составьте программу для нахождения площади прямоугольника по заданным сторонам а и б

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);



Вы находитесь на странице вопроса "Составьте программу для решенияСоставьте программу для решения следующей задачи с использование цикла", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.