Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите в программе Pascal (линейный, ветвление и циклический)

10-11 класс

АлисаРыбакова 25 февр. 2017 г., 9:53:35 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
оля290701
25 февр. 2017 г., 12:08:50 (7 лет назад)

var 
a,n,x,p1,p2:integer;
begin
readln(n);
x:=-1;
a:=0;
p1:=1;
p2:=1;
while abs(a)<n do begin
x:=x*(-1);
a:=(abs(a)+1)*x*(-1);
if abs(a)mod 2=0 then
p2:=p2*a
else
p1:=p1*a;
end;
writeln(p1);
writeln(p2);
end.

Ответить

Другие вопросы из категории

Сообщение записано с помощью двоичного кода. Его длина

2048 символов. Каков объём этого сообщения в килобайтах?

решение полное! срочно,пожалуйста

1)=НЕ(A2)

2)=И(A2;B2) 3)=ИЛИ(A2;B2) как это в Excel написать

Читайте также

В программе Pascal ABC

Помогите составить программы

Помогите сделать программу pascal. В одномерном массиве с четным количеством элементов (2N) находятся координаты N точек плоскости. Они располагаются в сле

дующем порядке: x1y1х2, у2, х3, у3, и т. д. Определить кольцо с центром в начале координат, которое содержит все точки.

Помогите,пожалуйста, написать программу по теме "Ветвление в алгоритмах" для Pascal. Задача: определить существует ли треугольник со сторонами AB

C и, если существует, то какой он (равнобедренный, равносторонний, произвольный).

Заранее большое спасибо!

Помогите создать программу в С/С++ и Pascal При запуске программы, она должна предлагать 5 действий При нажатии 1-должен создаваться файл dat При нажатии

2-должны выводиться данные 20 учеников (название группы; порядковый номер ученика; имя; фамилия; год рождения; 5 оценок по разным предметам) из файла на экран При нажатии 3-добавление одного или нескольких учеников в список по вышеперечисленным критериям При нажатии 4-Вывести на экран учеников или ученика с минимальным средним баллом При нажатии 5-Вывод списка учеников в txt документ в порядке убывания средних оценок *После каждого действия должно задавать вопрос("продолжить работать в программе или выйти?")

помогите написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет"

const
N=20;
var
a:array [1..N] of integer;
i,j,max:integer;
begin
for i:= 1 to N do
readln(a[i]);
max:=99;
j:=a[i];
for i:= 1 to N do
if (j>99) and (j<999) and (j mod 9 <>0) and (j>max) then max:=j;
if max>99 then writeln (max) else writeln ('no');
readln;
end.

программа проверяет только последнее число, а не все 20. где ошибка?



Вы находитесь на странице вопроса "Помогите в программе Pascal (линейный, ветвление и циклический)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.