Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

С клавиатуры вводят строку, состоящую из латинских букв

5-9 класс

и цифр. Написать программу, которая вычисляет сумму цифр, попадающихся в этой
строке, а также выводящую строку после исключения из неё этих цифр.

Bestthebest 27 февр. 2017 г., 21:24:14 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Danka45
28 февр. 2017 г., 0:06:52 (7 лет назад)

var s,al:string;a,i:integer;
begin
read(s);
al:='1234567890';
i:=length(s);
while i>0 do begin
if poa(s[i],al)<>0 then begin a:=a+strtoint(s[i]);delete(s,i,1);end;
i:=i-1;
end;
writeln(Сумма: ',a);
writeln('Строка без цифр: ',s);
end.

Ответить

Другие вопросы из категории

на столб высотой 1 метр ползёт улитка.В период с 00:00 по 12:00 улитка сползает по столбу на 10 см,а в период с 12:00 по 24:00 поднимается на25

см.Сколько часов понадобится улитке чтобы достичь вершины столба,если она начала ползти от основания стоба в понедельник в 12:00?(ответ объясните)

В соревнованиях по прыжкам в длину участвуют 25 спортсменов, с клавиаиуры ввести номер спортсмена и его результат ( номер спортсмена не связан с

очередностью). Написать программу, которая выводит на экран номер и результат худшего и лучшего спортсменов. все это как то связанно с оператором повтора FOR

18. Предложены команды:

1. создать файл gramota.doc;

2. создать каталог NEW;

3. создать каталог SCHOOL;

c) стирается на ""жестком диске'";

d)стирается на магнитном диске;

e) стирается на компакт-диске.

d)файл, защищенный от несанкционированного доступа;

e) файл, зараженный компьютерным вирусом.

4. войти в созданный каталог;

5. сделать диск С: текущим.

Расположите пронумерованные команды так, чтобы был получен алгоритм, с помощью которого на пустой дискете создается файл с полным именем C:\SCHOOLY\NEW\gramota.doc

a) 5; 2; 3; 1;

b) 5; 1; 3; 4; 2;

c) 5;3:4;2;4; 1;

d) 5; 1: 2; 3; 4;

e) 1;3;2;5.

1.9. «... памяти означает, что любая информация заносится в память и извлекается из нее по...». Вместо многоточий вставить соответствующие слова:

a) дискретность; адресам; d) адресуемость; байтам;

b) адресуемость; значениям; е) адресуемость; адресам.

c) дискретность; битам;

20. В системное ПО ходят:

a) языки программирования:

b) операционные системы;

c) электронные таблицы;

d) совокупность всех программ, установленных на компьютере:

e) графические редакторы

Читайте также

все пятибуквенные слова составленные из латинских букв F,N,S ЗАПИСАНЫ В АЛФАВИТНОМ ПОРЯДКЕ

1.FFFFF
2.FFFFN
3.FFFFS
4FFFNF
5.........
.Определите слова которые будут идти в этом списке 7,27,90,101,196.Возможно вам будет проще ответить на третий и четвертый вопрос если вы будете знать,что на 99-ом месте в этом списке стоит строка NFNSS
в ОТВЕТЕ НУЖНО ЗАПИСАТЬ ПЯТЬ СТРОК СОСТОЯЩИХ ИЗ ЛАТИНСКИХ БУКВ.Ответ на каждое задание нужно писать в отдельной строке.(в 1 строке слово стоящее 7-ым,во 2-ой слово стоящее 27-ым,и далее 90,101 и 196 также)Порядок записи слов менять нельзя

Строки (цепочки символов латинских букв) создаются по следующему правилу.

Первая строка состоит из одного символа – латинской буквы «А». Каждая из последующих це-почек создаётся такими действиями: в очередную строку сначала записывается буква, чей поряд-ковый номер в алфавите соответствует номеру строки, к ней слева дважды подряд приписывает-ся предыдущая строка.
Вот первые 4 строки, созданные по этому правилу:
(1) A
(2) AAB
(3) AABAABC
(4) AABAABCAABAABCD
Выпишите буквы, которые могут стоять в 256 позиции в девятой и всех последующих стро-ках. Ответ обосновать. Латинский алфавит для справки: ABCDEFGHIJKLMNOPQRSTUVWXYZ

Строки (цепочки символов латинских букв) создаются по следующему правилу.

Первая строка состоит из одного символа – латинской буквы «А». Каждая из последующих це-почек создаётся такими действиями: в очередную строку сначала записывается буква, чей поряд-ковый номер в алфавите соответствует номеру строки, к ней слева дважды подряд приписывает-ся предыдущая строка.
Вот первые 4 строки, созданные по этому правилу:
(1) A
(2) AAB
(3) AABAABC
(4) AABAABCAABAABCD
Выпишите буквы, которые могут стоять в 256 позиции в девятой и всех последующих стро-ках. Ответ обосновать. Латинский алфавит для справки: ABCDEFGHIJKLMNOPQRSTUVWXYZ

пожалуйста помогите!



Вы находитесь на странице вопроса "С клавиатуры вводят строку, состоящую из латинских букв", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.