Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу вычисления N!,где N- натуральное числоБвводится с клавиатуры.Паскаль,срочно.

5-9 класс

Anushkakovalova 17 авг. 2013 г., 14:52:36 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
арсения5578
17 авг. 2013 г., 17:09:01 (10 лет назад)

var

n,a,i:integer;

begin

read(n);

for i:=1 to n do

a:=a*i;

write(a);

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ответить

Другие вопросы из категории

1. ЛАЗЕРНАЯ СИГНАЛИЗАЦИЯ 1 В процессе модернизации технического обеспечения и применения новых информационных

технологий для защиты от воров вокруг банка поставили лазерную сигнализацию, которая состоит из нескольких лазерных станций. Станции ставятся по периметру здания, и между соседними станциями проходит лазерный луч. Также каждые соседние станции соединены кабелем. Известны координаты всех станций в порядке их обхода «по» или «против» часовой стрелки. Вам, как отличнику учебы, поручили ответственное задание – посчитать суммарную длину кабеля, который соединяет станции.

Входные данные

В первой строке находятся целое N – число базовых станций (1<=N<=2*10^6).

В следующих N строках – по два вещественных числа x, y (|x|<=10^4, |y|<=10^4), разделённых пробелом: координаты каждой станции (в прямоугольной декартовой системе координат).

Результат

Необходимо вывести суммарную длину кабеля, который потребуется проложить, с точностью до двух знаков после точки.


Примеры входных и выходных данных:

Входные данные 5 -1 -1 -1 1 1 1 2 0 1 -1

Выходные данные 8.83

Что делает барометр? и рулетка?

Читайте также

Написать программу Turpo pascal помогите пожалуйста что сможете!!! Вывести на экран 6 раз свое имя. Составить блок-схему и написать программу

вычисления суммы чисел от 6 до 10. Написать программу вычисления n! (факториал числа n), где n- целое неотрицательное число.

Определение факториала:

0!=1, 1!=1, 2!=1*2, 3!=1*2*3, ……,n!=1*2*3*…*(n-1)*n.

Другими словами n!- это произведение n натуральных чисел.

Требовалось написать программу вычисления факториала числа n (факториал числа n есть произведение всех целых чисел от 1 до n). Программист торопился и

написал программу неправильно. Ниже приведён фрагмент его программы, в котором содержится пять ошибок:

k:=1;

f:=0;

while k<n do

f:=f*k;

k:=k+1

1)Написать программу вычисления модуля разность двух данных целых чисел 2)Составить программу вычесляет в котором n суток, часов, минут,

секунд.

3)Составте программу вычисления площади треугольника с основанием а и высотой h. Значение a и h введите с клавиатуры.

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.



Вы находитесь на странице вопроса "Написать программу вычисления N!,где N- натуральное числоБвводится с клавиатуры.Паскаль,срочно.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.