Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Очень нужна помощь в редактировании программы. Данная программа должна заменять на число 1000 ТОЛЬКО ПЕРВЫЙ элемент, кратный 4, а у меня заменяются все

5-9 класс

элементы, кратные 4. Где ошибка?
program zamena;
var akrat,i,n:integer;
a:array[1..1000] of integer;
begin
assign (input,'input.txt');
assign (output,'output.txt');
reset (input);
rewrite (output);
readln(n);
for i:=1 to n do read (a[i]);
akrat:=a[1];
for i:=1 to n do
begin
if a[i] mod 4=0 then
a[i]:=1000;
end;
for i:=1 to n do
writeln(a[i]);
close (input);
close (output);
end.

Lariska1975 23 янв. 2014 г., 5:56:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Rafikarafika
23 янв. 2014 г., 7:30:09 (10 лет назад)

Program Zamena;
Var akrat,i,n:integer;
      a: Array[1..1000] Of Integer;
Begin
   Assign (input,'input.txt');
   Assign (output,'output.txt');
   Reset (input);
   Rewrite (output);
   Readln(n);
   For i:=1 To n Do Read (a[i]);
      akrat:=a[1];
    For i:=1 To n Do
   If a[i] mod 4=0 then
   Begin
       a[i]:=1000;
       Break;
       End;
   For i:=1 To n Do
   WriteLn(a[i]);
   Close(input);
   Close(output);
End.

+ 0 -
НикКита666
23 янв. 2014 г., 9:00:59 (10 лет назад)

var
    i, n: integer;
    a: array[1..1000] of integer;

begin
    readln(n);
    for i := 1 to n do
        read(a[i]);
   
    for i := 1 to n do
        if a[i] mod 4 = 0 then begin
            a[i] := 1000;
            break;
        end;
       
    for i := 1 to n do
        write(a[i], ' ');
end.

Ответить

Другие вопросы из категории

Выполните сложение в двоичной СС:

1011101^2+101101^2
Выполните умножение в двоичной СС:
а)1101011^2*1011^2
б)1011101^2*1101^2

Укажите к каким информационным процесам относится:сьёмка кинофильма размышление телефоный разговор ксерокопирывание ответ ученика на уроке написание

письма кодирыване сообщений написание контрольной работы выставление семестровой оценки ведения дневника фотографирывание ведение записей на уроке показ пантомимы отправка письма

Читайте также

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.

Нужна помощь в составлении алгоритма (паскаль АВС) -8 класс.

1 задание: Составьте программу вычисления количества двухзначных чисел,которые кратны 2 и 3.
2 задание: Составьте программу,выводящую на экран все двузначные числа,у которых первая цифра в два раза больше второй.
3 задание: Найдите количество двузначных чисел,которые делятся на сумму своих цифр.
P.S. Помогите пожалуйста! Очень нужно и срочно! Если можете,то нужно всё сделать; если же нет,то хотя-бы одну или две задачи. Заранее спасибо!!!)))

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.

Определите значение переменной с после выполнения следующего фрагмента программы:

а:=9
а:= 25-а*а
b:= - а
c:+ 10 * а - b

Очень нужна помощь !!



Вы находитесь на странице вопроса "Очень нужна помощь в редактировании программы. Данная программа должна заменять на число 1000 ТОЛЬКО ПЕРВЫЙ элемент, кратный 4, а у меня заменяются все", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.