Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Записать последовательность операторов для решения задачи:

10-11 класс

Дано описание:
type month = 1..12;
var d:28..31;
m:month;
Переменной d присвоить количество дней в месяце m (год считать не високосным)

Osmonbaeva86 23 окт. 2016 г., 7:38:16 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yers1n
23 окт. 2016 г., 10:14:38 (7 лет назад)

Даже не знаю. Так?

type month=1..12;
var d:28..31;
m:month;
begin
read(m);
case m of
1,3,5,7,8,10,12:d:=31;
4,6,9,11:d:=30;
2:d:=28;
end;
write(d)
end.

+ 0 -
Nfhfctyrjcfytxrf
23 окт. 2016 г., 11:02:17 (7 лет назад)

Можно про это задание подробнее? Программа? На каком языке?

Ответить

Другие вопросы из категории

Решите четвертую задачку в pascal
ребят, я не программист, пожалуйста помогите!

Тут надо что то поменять , чтобы выполнилось действие

Задание1
Вывести одномерный массив состоящий из 6 элементов . Выведите на экран 3 элемент умножав его на 10

Задание 2
Задан массив с 6 элементами, вывести все элементы массива умножив на 10

Читайте также

помогите с задачей. я написала решение, но где-то ошибка видимо. подскажите где именно и ошиблась. Смоделировать работу автомата по продаже

билетов. Пусть населенные пункты обозначены номерами 1, 2, 3, 4, 5, 6, 7, 8. Стоимость одного билета к конкретному пункту определена так:

22,k=1

35,k=2,3

50,k=4

72,k=5,6

97 во всех остальных случаях.

Сколько будут стоить m билетов к некоторому населенному пункту? Для решения задачи используйте алгоритмическую конструкцию "выбор" (case).

program z5;

var

r, m, n, s:integer;

begin

writeln('r=', r);

readln(r);

writeln('m=', m);

readln(m);

case r of

1:n:=22;

2,3:n:=35;

4:n:=50;

5,6:n:=72;

else n:=97;

end;

s:=m*n;

writeln('s=', s);

end.

Циклические алгоритмы.СоставьтеЦиклические алгоритмы.Составьте блок- схему для решения следующих задач:

1) Вводятся 100 чисел.Определить сколько среди них положительных и сколько отрицательных.(Числа вводятся в одну переменную в цикле)
2) Алгоритм вычисления суммы квадратов десяти производных чисел, водимых с клавиатуры в процесс выполнения алгоритма
И НАПИШИТЕ ПРОГРАММУ ДЛЯ КАЖДОЙ ЗАДАЧИ

Разработать программу для решения задачи, ввод данных организовать через рабочий лист MS Excel (Написать код)

Из данного массива А трехзначных чисел записать в массив В элементы, содержащие цифру 5.
Исходные данные на картинке. Заранее Спасибо!

Задание: составить программу решения задачи.

Указания к выполнению: самостоятельно выполнить все этапы решения
задачи. Ввод и вывод матрицы оформить в виде процедур. При
необходимости выделить в задаче вспомогательные алгоритмы и оформить
их в виде подпрограмм.паскаль

Дана матрица, определить количество «особых» элементов. Элемент
считается «особым», если он больше суммы остальных элементов строки.
.



Вы находитесь на странице вопроса "Записать последовательность операторов для решения задачи:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.