Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Каждая бактерия делится на 2 в течении 1 минуты.в начальный момент(t=0) имеет 1 бактерию.Переислите сколько их встанет через 15 минут?Нужно составить

5-9 класс

программу
program xxx;

VAR:..
и т.д.
Помогите пожалуйста,пропустила эту тему а завтра контрольная:с

Kriskristina9 02 окт. 2013 г., 13:14:49 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
мулечка10
02 окт. 2013 г., 15:32:57 (10 лет назад)

 

Как то так, но может быть неправельно.

 

1 var
2  Bakteriya, Vremya: integer;
3  i: byte;
4 begin
5  Bakteriya:=1; Vremya:=15;
6  i:=2;
7   while i <= Vremya do
8    begin
9       Vremya:=Vremya-1;
10     Bakteriya:=Bakteriya*2;
11   end;
12  writeln('Кол-во бактерий через 15 минут: ', Bakteriya);
13 end.

 

 

 

Ответить

Читайте также

Очень надо. В ИКТ полный ноль. Нужен паскаль и блок схема. Вот сама задача:Каждая бактерия делится на две в течении 1 минуты. В начальный

момент имеется одна бактерия. Составьте блок-схему алгоритма вычисления количества бактерий через 10 минут. Исполните алгоритм, фиксируя каждый его шаг в таблице значений переменных.
Заранее спасибо, надеюсь на вашу помощь)

Каждая бактерия делится на две в течение одной минуты. В начальный момент времени имеется одна бактерия. Составьте программу, которая рассчитывает

количество бактерий на заданное пользователем с клавиатуры целое значение момента времени 15 минут. Мне через Паскаль нужно и еще что бы через операторы white и do.Срочно нужно спасибо заранее.

Для того чтобы число делилось на 10,

1)необходимо
2)достаточно
3)необходимо и достаточно
, чтобы оно делилось на 5

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].

Помогите написать программы >< Задача 1: Среди целых чисел найти минимальное число, которое больше 20 и делится на 17. Задача 2:

Найти максимальное натуральное число меньше 5000, которое делится нацело на 39.

Задача 3: 1 марта в банк положили 1000 руб. Каждый месяц вклад увеличивается на 2% от имеющейся суммы.

а) за какой месяц величина процентной надбавки превысит 30 руб.?

б) через сколько месяцев размер вклада превысит 1200 руб.? Заранее спасибо)



Вы находитесь на странице вопроса "Каждая бактерия делится на 2 в течении 1 минуты.в начальный момент(t=0) имеет 1 бактерию.Переислите сколько их встанет через 15 минут?Нужно составить", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.