Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу в Pascal ABC: Нахождение площади треугольника.

5-9 класс

каринас 14 нояб. 2013 г., 18:15:26 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ilrdn
14 нояб. 2013 г., 20:47:25 (10 лет назад)

var
  // координаты вершин
  c: array [,] of real := ((0,0), (1,0), (0,1));
  sides: array[0..3] of real; // длины сторон
  s,p: real;
  i,n: integer;
begin
  // вычисляем длины сторон
  for i := 0 to 2 do begin
    n := (i+1) mod 3;
    sides[i] := sqrt(sqr(c[i, 0] - c[n, 0]) + sqr(c[i, 1] - c[n, 1]));
    p := p+sides[i]/2;
  end;
  
  // формула Герона
  s := p;
  for i := 0 to 2 do
    s := s * (p - sides[i]);  
  
  writeln(sqrt(s));
end.

Ответить

Читайте также

Составить программу нахождения площади треугольника по формуле Герона.

Входные данные длины сторон треугольника.
Выходные данные периметр треугольника, площадь треугольника.

Написать программу Turpo pascal помогите пожалуйста что сможете!!! Вывести на экран 6 раз свое имя. Составить блок-схему и написать программу

вычисления суммы чисел от 6 до 10. Написать программу вычисления n! (факториал числа n), где n- целое неотрицательное число.

Определение факториала:

0!=1, 1!=1, 2!=1*2, 3!=1*2*3, ……,n!=1*2*3*…*(n-1)*n.

Другими словами n!- это произведение n натуральных чисел.



Вы находитесь на странице вопроса "Написать программу в Pascal ABC: Нахождение площади треугольника.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.