Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программу в паскале и записать логику, без массива!

5-9 класс

Три числа найти большее и наименьшее этих чисел и сравнить , большее с наименьшим и наименьшее с большим . Буду очень благодарна

Katushka2003d 06 февр. 2014 г., 23:10:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kanra123
06 февр. 2014 г., 23:58:27 (10 лет назад)

program p1;
var a,b,c,d,e,f,g:real;
begin
readln(a,b,c);
if (a>b) and (a>c) then d:=a;
if (b>a) and (b>c) then  d:=b;
if (c>b) and (c>a) then  d:=c;
if (a<b) and (a<c) then e:=a;
if (b<a) and (b<c) then  e:=b;
if (c<b) and (c<a) then  e:=c;
f:=d-e;
g:=d+e;
writeln ('большее=', d , '; меньшее= ',e, '; разность= ',f,'; сумма= ',g);
end.

Ответить

Другие вопросы из категории

решите 6 и 7 ))))))))
Помогите решить 2 задачи...

1) Вывести на экран квадрат наибольшего из 2 введенных чисел?
2) Вывести на экран корень наибольшего из 3 введенных чисел?

на полустанке одноколейной железной дороги остановился поезд в составе тепловоза и трех вагонов, доставивший бригаду рабочих для строительства второго

пути. Пока же на этом полустанкеимеется небольшой тупик, где при необходимости может поместиться тепловоз с вагоном или два вагона. Вскоре к тому же полустанку подошел грузовой состав( тепловоз и 7 цистерн) как пропустить пассажирский поезд?

Паскаль, цикл while

Вводятся числа, посчитать кол-во чисел, которые делятся на 2 и которые делятся на 3. Ввод закончить 0. Вывести на экран кол-во чисел , делящихся на 2 и кол-во чисел, делящихся на 3.
помогите, пожалуйста

Читайте также

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль

Поомогите, пожайлуста. Нужно составить программу на паскале. Ежемесячная стипендия студента составляет a руб.Расходы на проживание превышают стипендию

и составляют b руб(в месяц).Рост цен ежемесячно увеличивает расходы на 3%,составьте программу расчета необходимой суммы денег,которую нужно единовременно попросить у родителей,чтобы можно было прожить 10 месяцев,используя эти деньги.

СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ.

Агент 007 узнал, что в секретном сейфе трёхзначный код, в котором все три цифры разные.При этом средняя цифра равна разности крайних цифр. Составить программу, которая напечатает для него все такие числа.

Помогите составить программу по Паскалю, пожалуйста.

Клоун
предложил каждому из публики задумать число. Потом он сказал: «Прибавьте к
задуманному числу 5. Теперь из результата вычтите 2. А теперь к результату
прибавьте 7». Потом клоун спросил у желающих, какое число у каждого из них
получилось. Услышав ответ, он немедленно объявлял каждому, какое число тот
задумывал. Составьте программу, которая повторяла бы фокус клоуна.

НАПИСАТЬ ПРОГРАММУ В ПАСКАЛЕ

составить программу которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный массив



Вы находитесь на странице вопроса "Составить программу в паскале и записать логику, без массива!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.