Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны

10-11 класс

действительные a, b, c, d. Используя функции
поиска максимума двух чисел max и минимума
двух чисел min, получить:
max(a, b)+min(a, b)
+min(c,d)
——————––––—––———
.
max(a, b, c, d) + min(a,b,c)

LLITOPMNK1659 10 июля 2014 г., 16:41:06 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lion300703
10 июля 2014 г., 17:34:58 (9 лет назад)

Program Task;
Var a, b, c, d: Integer;
Function Max(a, b: Integer): Integer;
Begin
If a > b Then
Result := a
Else
Result := b;
End;
Function Min(a, b: Integer): Integer;
Begin
If a < b Then
Result := a
Else
Result := b;
End;
Begin
Write('a = ');
ReadLn(a);
Write('b = ');
ReadLn(b);
Write('c = ');
ReadLn(c);
Write('d = ');
ReadLn(d);
WriteLn('max(a, b) + min(a, b) + min(c,d) = ', Max(a, b) + Min(a, b) + Min(c,d));
WriteLn('max(a, b, c, d) + min(a, b, c) = ', Max(Max(a, b), Max(c, d)) + Min(Max(a, b), c));
ReadLn;
End.

Ответить

Другие вопросы из категории

установите соответствие между информационными процессами и их характеристиками:1)изменение формы представления информации или ее содержания.2)процесс

передачи информации во времени.3)процесс передачи информации в пространстве

1)обработка.2)хранение.3)обмен

а)за контрольную работу учитель поставил 4 пятерки.Сообщение,что вы получили за контрольную пять,содержит 2 бит информации.Определите,сколько человек

всего в классе?

б)Известно,что сообщение учителя о том что к доске пойдет Саша Орлов,содержит 5 битов информации. Сколько учеников в классе?

Напишите пожалуйста программу для того, чтобы:

1) Найти сумму нечетных чисел в интервале от 1 до 20
2) Найти сумму четных чисел в интервале от 1 до 20

Читайте также

Данные, объемом 16 Мбайт, поступают на компьютер по линии со скоростью передачи данных 32 Мбит/с. После получения 4 Мбайт компьютер начинает одновременно

передавать эти данные по другой линии связи со скоростью 4 Мбит/с. Сколько секунд пройдет от начала приема данных по высокоскоростному каналу до полной передачи их по низкоскоростному каналу?

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.

C++Написать программу вычисления объема параллелепипеда. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные

пользователем, выделены полужирным шрифтом).

Вычисление объема параллелепипеда.

Введите исходные данные:

Длинна (см): 9

Ширина (см): 7.5

Высота (см): 5



Вы находитесь на странице вопроса "Даны", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.