Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дана строка символов.Подсчитать общее кол-во знаков (+,-,*), входящих в эту строку

5-9 класс

Masha092002 04 нояб. 2013 г., 5:10:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Masha29072001
04 нояб. 2013 г., 6:50:58 (10 лет назад)

решение на паскале.

 

var s:string;
i,a,b,c:integer;
begin
readln(s);
for i:=1 to length(s) do
if s[i]='+' then inc(a)
else if s[i]='-' then inc(b)
else if s[i]='*' then inc(c);
write('В этой строке: "+" - ',a,'; "-" - ',b,'; "*" - ',c)
end.

Ответить

Другие вопросы из категории

Сколько байтов в слове класс?
помогите решить пожалуйста, учитель бьется цветочком!

Составьте программу вычисления количества трехзначных чисел-палиндромов(чисел, которые читаются одинаково слева направо и справа налево).

Помогите СРОЧНО,нужно написать какие программы в компьюторе мне нра...

Какими программами я люблю пользоваться.....
Например: Я люблю слушать музыку в проигрователе AIMP3.....
Надо буквально 5-6 предложений....И программ примерно 3-4.....
ПОМОГИТЕ.....Зарание БОЛЬШОЕ спасибо*)

Паскаль шифр цезаря

почему при дешифровке в слове с буквой "в" в результате выдаёт восклицательный знак то есть не может его дешифровать?




program SHIFR_CEZERYA;
uses crt;
var a,b,c:string;
i,j,k,d,g:integer;
begin
clrscr;
writeln('Шифрование?1-да,0-нет');
readln(g);
writeln('Исходный текст ');
readln(a);
writeln('ключ');
readln(d);
c:=''; //Результат
b:='абвгдеёжзийклмнопрстуфхцчшщъыьэюя';
for i:=1 to length(a) do //цикл
for j:=1 to length(b) do
begin
If g=1 then k:=(j+d) mod 33 else k:=(j-d)mod 33;
If k>33 then k:=k-33;
if k<0 then k:=k+33;
if a[i]=b[j] then c:=c+b[k];
end;
writeln(c);
readkey;
end.

Читайте также

1. Дан массив из 6 натуральных чисел. Над элементами массива разрешено проделывать только одну операцию: менять местами менять местами любые два

расположенных рядом элемента. Какое минимальное кол-во раз необходимо выполнить эту операцию, для того, чтобы массив оказался отсортирован по убыванию?
2. Книга, набранная с помощью компьютерак, содержит 250 страниц. На каждой странице 45 строк, в каждой строке - 50 символов. Какой объем информации в байтах содержится в книге?
3. Объем видеопамяти составляет 62.5 Мбайт. Графический дисплей работает в режиме 320 х 400 пикселей. Какое максимальное кол-во цветов может содержать палитра?

_____________________________________________________

Если можно с объяснением,пожалуйста...)

Задачи на кол-во информации)

1. Определите информационный объем текста в кавычках. Кавычки не учитывать: "Приучайтесь думать точно!"
2. На дискете помещается 1,4 Мб информации. Сколько дискет может заменить один жесткий диск, емкостью 420 Мб?
3. Сколько необходимо памяти (в Мб), чтобы сохранить картинку, которую мы видим на экране, если про монитор известно: кол-во точек 800*1200, кол-во цветов - 521?
4. а) в следующих записях проставьте знаки отношений:
3,2 Гбайта 4000 Мб
7 байт 55 бит
8150 байт 8 Кб
б) дополните равенства
9 байтов=___битам
20 Мбайтов=___Кб
5. Информация передаётся со скоростью 3 Кб/сек. Какой объем информации будет передан за 20 минут? Ответ дать в Мб.

Ребят помогите пожалуйста! 1. Кол-во страниц 65 Кол-во строк в странице 70 Кол-во символов в строке 52 Информационный

объем? В мегабайтах

2. 179 Мбайт- перевести в биты

71 Мбайт - перевести в байты

3. Перевести в десятичную, двоичную, восьмеричную, шестнадцатеричную системы 147 180 210

Составьте задачу на вычисление количества информации от количества возможных событий

Например: В рулетке общее кол-во штук 64. Какое кол-во информации мы получим в зрительном сообщении об остановке шарика в одной из лунок?
Дано: Решение:
N=64 N=2i
64=2i
64=26
i=? i=6 бит

1.Какое кол-во информации получит Миша после броска кубика с 16 гранями?

2.Играя в игру "Угадай число" было получено 6 бит информации. Каково было кол-во возможных событий?
3. Маша переехала в многоэтажный дом, и сообщение о том,что она живет на 24 этаже,несет 5 бит информации.Сколько этажей в доме?



Вы находитесь на странице вопроса "дана строка символов.Подсчитать общее кол-во знаков (+,-,*), входящих в эту строку", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.