Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

задача в паскале помогите!!!!! из числа а(четырёхзначное) получить число b записанное в обрадном порядке

5-9 класс

Jonyk 07 февр. 2014 г., 19:33:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tanya1234567891011
07 февр. 2014 г., 22:04:46 (10 лет назад)

вроде так, я уже давно в паскале не работала

 

 

program abcd;

uses crt;

var a,b,c,d,e,f,g,h:integer;

begin

Clrscr;

writeln("a=",a);

readln(a);

c:=a div 1000;

d:=a mod 1000;

e:=d div 100;

f:=d mod 100;

g:=f div 10;

h:=f mod 10;

b=h*1000+g*100+e*10+c;

readln(c);

readln; 

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Ответить

Другие вопросы из категории

Мини-проект 2 («Kv_uravn»).

Создайте проект для расчёта корней квадратного уравнения. Продумайте названия
текстовых полей, чтобы не запутаться при программировании. Чтобы поставить
«квадрат» для икса, просто используйте ещё одну метку (Label). При нажатии на кнопку
«Рассчитать» вычисляется дискриминант, и, если он меньше нуля, то сразу
выдаётся сообщение «Корней нет» (через MsgBox), если равен нулю, то рассчитывается только значение X1, а если больше нуля – то X1 и X2. Рассчитанные значения корней должны
появиться в соответствующих текстовых полях на форме. Пример вида формы показан
на рисунке:

как называется свойство алгоритма, означающее, что каждая команда определяет однозначное действие исполнителя?

а) дискретность
б) понятность
в) точность
г) конечность

ПОМОГИТЕ!!!! В некоторой стране автомобильный номер длиной 7 символов составляют из заглавных букв (задействовано 25 различных букв) и десятичных цифр

в любом порядке. Каждый такой номер в компьютерной программе записывается минимально возможным и одинаковым целым количеством байт (при этом используют посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством бит). Определите объем памяти, отводимый этой программой для записи 40 номеров. 1) 120 байт 2) 160 байт 3) 200 байт 4) 240 байт

Читайте также

ПОМОГИТЕ СРОЧНО ПОЖАЛУЙСТА. РЕШИТЬ БЛОК-СХЕМОЙ

В трехзначном числе x зачеркнули его вторую цифру, когда к образованному при этом двузначному числу приписали вторую цифру числа x, то получилось число n. Найдите число x

Введите с клавиатуры целое число в диапазоне 1-999.

а)Определите количество знаков в числе;
б)Определите четность числа;
в)Выведите описание числа,например,"нечетное однозначное число","четное двухзначное число" и тд.
Пример ввода: 347
Пример вывода: Нечетное трехзначное число

Введите с клавиатуры целое число в диапазоне 1-999.

а) определите количество знаков в числе;
б) определите чётность числа;
в) выведите описание числа ,наприме нечётное одназначное число чётное двухзначное число

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА



Вы находитесь на странице вопроса "задача в паскале помогите!!!!! из числа а(четырёхзначное) получить число b записанное в обрадном порядке", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.