Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

организовать на языке си ++ ветвления вариант 18

10-11 класс

Lublualgebru 14 янв. 2016 г., 11:47:01 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lokk2002
14 янв. 2016 г., 12:36:00 (8 лет назад)

Решение во вложении.

Ответить

Другие вопросы из категории

Задание1 Сформировать одномерный массив из 10 элементов (значения элементов задаются случайным образом из диапазона [10, 40]). Если элемент меньше 25 –

заменить его квадратом индекса, иначе - увеличить элемент на 5. Вывести на экран исходный и итоговый массивы. задание2 Сформировать одномерный целочисленный массив размерностью N. Поменять местами первый элемент со вторым и последний с предпоследним. Вывести на экран исходный и итоговый массивы.

1) Требовалось написать программу,1) Требовалось написать программу, которая определяет, можно ли построить треугольник из отрезков с длинами х, у,

z. Программа должна выводить соответствующее текстовое сообщение. Программист сделал в программе ошибки.
var х, у, z: real;
begin
readln (x, у, z);
if (x + y > z) then
begin
if (x + z > y) then i
f (y + z > x) then
writeln('треугольник построить можно');
end
else writeln('треугольник построить нельзя');
end
Последовательно выполните задания: 1. Приведите пример таких чисел х, у, z, при которых программа неверно решает поставленную задачу. 2. Укажите, как нужно доработать программу, чтобы не было случаев ее неправильной работы (можно указать один из способов доработки исходной программы). 3. Укажите, как можно доработать программу, чтобы она вместо вложенных операторов IF содержала логическую операцию AND.

Что будет выведено на экран после выполнения следующих операторов:

p:=1; i:=1;
repeat p: = p*2
i: =i-1;
until i<1;

Читайте также

Напишите на языках Pascal и C++ программу, которая генерирует 2 случайных вещественных числа и вычисляет их сумму, разность, произведение и

частное. Напишите на языках Pascal и C++ программу, моделирующую выбор одной из костей домино ( в наборе 28 костей домино, каждая состоит из двух половин, на каждой половине – от 0 до 6 очков). С помощью этой программы ответьте на вопрос: какова вероятность того, что выпадет кость с числом очков, кратным 3

3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б)y=x¹⁵ или а) y=x^10

б)y=x^15

Постараться использовать минимальное количество дополнительных переменных.

4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a ← b ← c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

1)Вычислить значения функции y=4*x^3-2*x^2+5 для x, изменяющегося от -3 до 1 с шагом 0,1 на языке ПАСКАЛЬ!!СРОЧНОО ЗАВТРА ЭКЗАМЕН РЕБЯЯТКИ!

2)Найти количество всех нечетных чисел на интервале от 11 до 20
3)Найти сумму целых положительных четных чисел на интервале от 1 до 100
4)Найти сумму ряда,общий член которого равен А(х)=1/(3*N-2)*(3*N+1)
5)Дано произвольное число n≤100.Определить количество цифр в числе
ОЧЕНЬ НУЖНО!!НА ЯЗЫКЕ ПАСКАЛЬ!ВЫРУЧАЙТЕ!



Вы находитесь на странице вопроса "организовать на языке си ++ ветвления вариант 18", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.