Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите с программами, пожалуйста. Pascal.

10-11 класс

1) Из трех, задаваемых с клавиатуры чисел a, b, c, найти сумму наименьшего и наибольшего из этих чисел.

2) Найти среднеарифметическую температуру воздуха за N дней. Число дней и температуру воздуха каждого дня задать самостоятельно.

Nastyavaranica 07 авг. 2013 г., 3:59:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
231852
07 авг. 2013 г., 4:35:55 (10 лет назад)

Первая задача(я проверил программу, все норм работает)
var a,b,c,max,min,S:real;
begin read(a,b,c);
if a>b then if a>c then max:=a
else max:=c
else if b>c then max:=b
else max:=c;
if a<b then if a<c then min:=a
else min:=c
else if b<c then min:=b
else min:=c;
S:=max+min;
writeln(S:2:2);
end.

Ответить

Другие вопросы из категории

12. Файлы с

расширением .

Помогите ничего не понимаю.
Расшифруйте слова

1) 110001101100100011000111110011011101110
2) 1100101011001110110010111100000011010000

Читайте также

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ В PASCAL! ПОЖАЛУЙСТА!

Дан массив X(N,M). Если первый элемент массива положительный, то найти сумму элементов среди элементов четных строк массива, иначе произведение.

помогите составить программу!пожалуйста!!!!ооочень надо

ракета запускается с земли со скоростью V(км час) в направлении движения земли по орбите вокруг солнца. составить программу,определяющую результат запуска ракета в зависимости от скорости V.
Известно,что при V16,4 ракета покинет солнечную систему.

Помогите написать программу в pascal
Помогите составить программу, пожалуйста, нужно очень срочно! Пятиугольник ABCDE задан координатами своих вершин

(X1,Y1)(X2,Y2)(X3,Y3)(X4,Y4)(X5,Y5) соответственно. Найти площадь этого пятиугольника используя в качестве подпрограммы a) функцию

Пк запрашивает название и радиусы орбит двух планет (в миллионах км) и скорости движения орбит (в миллионах км в сутки). Вычислить продолжительность

года на планетах (длина орбит/скорость). Результаты должны иметь вид:

Продолжительность года на планете <имя1> суток;

Продолжительность года на планете <имя2> суток;

Помогите составить программу в Pascal.



Вы находитесь на странице вопроса "Помогите с программами, пожалуйста. Pascal.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.