Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Сформировать массив из 10 целочисленных элементов (от 1 до 15) и вывести на экран. Найти произведение всех элементов массива.

5-9 класс

Gunidinaveronika 12 марта 2015 г., 16:52:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Linovala
12 марта 2015 г., 19:19:20 (9 лет назад)

var 
a: array [1..10] of byte; 
p: integer; 
i: byte;
begin 
p := 1; 
writeln('Массив:'); 
Randomize; 
for i := 1 to 10 do 
begin   
a[i] := Random(15) + 1;   
write(a[i]:4);   
p := p * a[i]; 
end; 
writeln; 
write('Произведение = ', p:4);
end.

Ответить

Другие вопросы из категории

Читайте также

Одномерный массив из 10 элементов с номерами от 10 до 20 заполнить случайным образом числами от 0 до 22. Все элементы массива,значения которых лежат между

10 и 20 включительно,увеличить в 5 раз.Вывести на экран монитора первоначальный и преобразованный массивы в столбик.

решить через паскаль через массивы)) 1.Дан одномерный массив из 10 элементов. Заменить все большие 7 члены массива числом 7. Найти количество

таких членов.

2.Дан массив из 10 элементов. Найти количество элементов с четными индексами.

3.Дан массив из 10 элементов. Найти наибольший элемент массива.

Решите пожалуйста программу в паскале:Составить программу, которая формирует массив из 10 случайных чисел от -30 до 30 и если третий элемент больше нуля,

то поменять местами третий и пятый элементы, если третий элемент равен нулю, то увеличить оба эти элементы в 2 раза, иначе третий и пятый элементы сохраняют прежние значения.

1) составьте программу заполнения элементов массива [1..10 ] случайнымии целыми числами на отрезке [ 0;35 ] и вывода на экран нечетных элементов и

кратных числу 3.

2) составьте программу , которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 100 и выводит на экран среднее арифмитическое элементов массива

Задача:

Дан массив из 10 целых чисел,от -20 до 20 .
Напишите программу,заменяющую первый отрицательный элемент массива нулем.

Помогите пожалуйста решить!



Вы находитесь на странице вопроса "Сформировать массив из 10 целочисленных элементов (от 1 до 15) и вывести на экран. Найти произведение всех элементов массива.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.