Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Помогите решить, и как вообще такое задание делать? Объясните:) Буду благодарна!!!

10-11 класс


Для каж­до­го из пе­ре­чис­лен­ных ниже де­ся­тич­ных чисел по­стро­и­ли дво­ич­ную за­пись. Ука­жи­те число, дво­ич­ная за­пись ко­то­ро­го со­дер­жит наи­боль­шее ко­ли­че­ство зна­ча­щих нулей.

Okuznetcov29 31 авг. 2013 г., 11:27:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
кирилл12312389
31 авг. 2013 г., 13:04:34 (10 лет назад)

Значащие нули в позиционных СС - это те нули (ну аналогично и единицы, девятки...) которые стоят до последней цифры с конца числа (то есть первой). Суть в том, что после этой самой цифры может быть ещё сколько угодно нулей, но они уже не значащие
1024=01024=0000000001024 здесь один значащий нуль, третий с конца

Алгоритм перевода из десятичной СС в двоичную найдёте на картинке ниже:) 65_{10}=1000001_{2}

В данном случае (1000001) здесь пять значащих нулей, а остальные, которых бесконечность и которые обычно не записывают, не в счёт

Ответить

Другие вопросы из категории

Размер имеющейся на диске файла составляет 1,25 мб сколько сочинений можно поместить в 1 такой файл, если среднее сочинение составляет 4 страницы по

16 строк, в строке 40 символов, сколько подобных файлов потребуется для хранения архива из 3000 сочинений?

Дан целочисленный массив из 10 элементов.Элементы массива могут принимать целые значения от -50 до 50.Составить программу ,позволяющую найти и

вывести сумму элементов массива которые кратны 7 и оканчиваются на 5 .Гарантируется,что в исходном массиве есть хотя бы один такой элемент.
НА ЯЗЫКЕ ПАСКАЛЬ!!!!

1. Что понимают под информацией?

2. Как вы понимаете, что такое "теория информации"?
3. С каким понятием тесно связано понятие алгоритма?
4. В чем заключается проблема создания искусственного интеллекта?
5. Попробуйте составить алгоритм узнавания кошки.

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

пожалуйста помогите подскажите как делать такое задание в delphi

Нужно СЕГОДНЯ итак надо по номеру дня недели определить чем вы занимаетесь в свободное время.Можно написать любые занятия.
3 разные виды занятия.
Описать когда свободное время ,тоесть действия не определены.



Вы находитесь на странице вопроса "Помогите решить, и как вообще такое задание делать? Объясните:) Буду благодарна!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.