Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помогите составить программу FREE PASCAL

5-9 класс

После каждой двойки вставить число 100

Gdfvvtynik 04 апр. 2014 г., 11:56:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vladi011
04 апр. 2014 г., 13:46:56 (10 лет назад)

Это как? Это надо чтобы программа выводила 2 после чего 100 ?

+ 0 -
кукутя
04 апр. 2014 г., 15:32:06 (10 лет назад)

Если я правильно понял, то дана строка, из букв и цифр, и после каждой 2 вставить число 100 и вывести его на экран ?
Если так, то лови : (извини, ABC pascal стоит)
program ss;
uses crt;
var a:string;
i,n :integer ;
begin
writeln ('vvedite');
readln (a);  n:=length (a);
if pos('2',a)=0 
then writeln ('chislo otsutstvuet') 
else begin
for i:=n downto 1 do  begin 
if a[i]='2' 
then  insert('100',a,i+1); 
end; 
end; 
writeln (a) 
end.

+ 0 -
Pestrikova02
04 апр. 2014 г., 17:55:01 (10 лет назад)

Сами понимаете, что написали? После какой "каждой двойки"?

Ответить

Другие вопросы из категории

Установите соответствие...

Установите соответствие...
Библиотека Смешанная(система)
Болото
Самолёт
Вулкан техническая система
Оркестр природная система
Степь

Система счисления

Ребят помогите плиз только начали изучать массивы надо решить задачу!

на паскале:
заполнить массив из 12 целых числе данных из клавиатуры.Найти сумму и кол-во всех отрицательных числе массива, заменить все числа которые больше десяти нулями.Вывести полученный массив на экран.
СПС за ранее как можно быстрее!

Читайте также

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а)

определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на...

Помогите составить программу по Паскалю, пожалуйста.

Клоун
предложил каждому из публики задумать число. Потом он сказал: «Прибавьте к
задуманному числу 5. Теперь из результата вычтите 2. А теперь к результату
прибавьте 7». Потом клоун спросил у желающих, какое число у каждого из них
получилось. Услышав ответ, он немедленно объявлял каждому, какое число тот
задумывал. Составьте программу, которая повторяла бы фокус клоуна.

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.




Вы находитесь на странице вопроса "помогите составить программу FREE PASCAL", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.