Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны три положительных числа. Если они могут быть длинами сторон треугольника, то определить его вид по сторонам, и по углам, иначе выдать

10-11 класс

соответствующее сообщение.


Решите разветляющим алгоритмом

Irina165aj 22 нояб. 2013 г., 19:07:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
илифия2000
22 нояб. 2013 г., 21:37:20 (10 лет назад)

var
a,b,c:integer;
x,y,z:string;
begin
writeln('Введите стороны треугольника');
readln(a,b,c);
x:='равнобедренный';
y:='равносторонний';
z:='разносторонний';
begin
if (c=b) and (a<>c) then
writeln('Треугольник',' ',x);
if (a=c) and (a<>b) then
writeln('Треугольник',' ',x);
if (a=b) and (a<>c) then
writeln('Треугольник',' ',x);
if (a=b) and (a=c) and (b=c) then
writeln('Треугольник',' ',y);
if (a<>b) and (a<>c) and (b<>c) then
writeln('Треугольник',' ',z);
end;
readln
end.

Ответить

Другие вопросы из категории

Работа в excel. Не знаю как делать подскажите как объясните очень надо.Сама задача:

Магазин по продажи компьютерных аксессуаров продает товары, указанные в прайс-листе (не менее 15 аксессуаров). Стоимость товара указана в долларах . Если стоимость товара превышает 1000 рублей, покупателю предоставляется 2% скидка, если более 5000 рублей - скидка 5%, если более 10000 рублей - 10% скидка, и если более 50000 рублей - скидка 20%.

Составить таблицу - шаблон, позволяющую быстро рассчитать стоимость произвольной покупки. В расчете учесть текущий курс доллара.

8. Сколько байт будет занимать изображение размером 375х285, если используется:

a. 16 цветов
b. 256 цветов
c. 2 цвета

Составить программу в Pascal
В городской олимпиаде по математике

по 5 и 6 классам приняли участие 59
детей. Каждому участнику
присваивается шифр - произвольное
число, оканчивающееся номером
класса, в котором он учится, оказалось,
что сумма шифров пятиклассников
равна сумме шифров шестиклассников.
На следующий год в олимпиаде по 6 и 7
классам приняли участие эти же 59
ребят. Могли ли суммы шифров этих
шестиклассников и семиклассников
оказаться равными? Ответ обоснуйте

помогите плииз написать программу на паскале

определить, поступит или нет абитуриент в ВУЗ, если известны его оценки за 4 экзамена и проходной балл поступления в ВУЗ.

Читайте также

Введите три числа.Если они могут быть длинами сторон остроугольного

треугольника,выведите их в порядке убывания и вычислите их площадь.

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.

Введите три числа. Если они могут быть длинами сторон равнобедренного остроугольного....

Ребят,подскажите пожалуйста как проверить могут ли быть стороны длинами равнобедренного остроугольного треуг. Не могу понять ,как проверить именно на остроугольный треугольник ,в геометрии 0. Помогите пожалуйста

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.



Вы находитесь на странице вопроса "Даны три положительных числа. Если они могут быть длинами сторон треугольника, то определить его вид по сторонам, и по углам, иначе выдать", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.