Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Выведите три числа. Если они могут быть длинами сторон прямоугольного треугольника выведите их в порядке возрастания и вычислите площадь полученного

10-11 класс

треугольника

Sof20011 04 мая 2015 г., 9:03:08 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Настюфеча
04 мая 2015 г., 11:28:21 (9 лет назад)

var
  s,p:real;
  i,j:integer;
  a:array[1..3]of real;
begin
readln(a[1],a[2],a[3]);
for i:=1 to 3 do
  for j:=1 to 3 do
  if a[j]>a[i] then
    begin
    p:=a[i];
    a[i]:=a[j];
    a[j]:=p
    end;
if a[1]+a[2]>a[3] then
  begin
  p:=(a[1]+a[2]+a[3])/2;
  s:=sqrt(p*(p-a[1])*(p-a[2])*(p-a[3]));
  for i:=1 to 3 do
    write(a[i],' ');
  writeln;
  writeln('Площадь треугольника: ',s);
  end
  else writeln('Треугольник не существует');
end.

Ответить

Другие вопросы из категории

11111111111111111111111111111111111111111111
В каждой больничной палате четыре койки. Введите количество палат, количество больных мужчин и количество больных женщин. Определите, можно ли

разместить всех больных по палатам (естественно, в одну палату кладут больных одного пола).

Читайте также

Введите три числа.Если они могут быть длинами сторон остроугольного

треугольника,выведите их в порядке убывания и вычислите их площадь.

Введите три числа. Если они могут быть длинами сторон равнобедренного остроугольного....

Ребят,подскажите пожалуйста как проверить могут ли быть стороны длинами равнобедренного остроугольного треуг. Не могу понять ,как проверить именно на остроугольный треугольник ,в геометрии 0. Помогите пожалуйста

1 задача : Даны

три положительных числа a,
b, c. Проверить,
могут ли они быть сторонами прямоугольного
треугольника.

В некотором вузе абитуриенты проходили предварительное тестирование, по результатам которого они могут быть допущены к сдаче вступительных экзаменов в

первом потоке. Тестирование проводится по трём предметам, по каждому предмету абитуриент может набрать от 0 100 баллов. При этом к сдаче экзаменов в первом потоке допускаются абитуриенты, набравшие по результатам тестирования не менее 30 баллов по каждому из трёх предметов, причём сумма баллов должна быть не менее 140. На вход программы подаются сведения о результатах предварительного тестирования. Известно, что общее количество участников тестирования не превосходит 500. В первой строке вводится количество абитуриентов, принимавших участие в тестировании, N. Далее следуют N строк, имеющих следующий формат: <Фамилия> <Имя> <Баллы> Здесь <Фамилия> – строка, состоящая не более чем из 20 символов; <Имя> – строка, состоящая не более чем из 15 символов, <Баллы> – строка, содержащая два целых числа, разделенных пробелом – баллы, полученные на тестировании по каждому из трёх предметов. При этом <Фамилия> и <Имя>, <Имя> и <Баллы> разделены одним пробелом. Пример входной строки: Романов Вельямин 48 39 55 Напишите программу, которая будет выводить на экран фамилии и имена абитуриентов, допущенных к сдаче экзаменов в первом потоке. При этом фамилии должны выводиться в алфавитном порядке.



Вы находитесь на странице вопроса "Выведите три числа. Если они могут быть длинами сторон прямоугольного треугольника выведите их в порядке возрастания и вычислите площадь полученного", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.