Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

помогите найти ошибку!

10-11 класс

дашулька02 11 марта 2015 г., 17:38:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
МашаСамойлова
11 марта 2015 г., 19:41:53 (9 лет назад)

попробуй real вместо integer

Ответить

Другие вопросы из категории

Два сообщения содержат одинаковое количество символов. Количество информации в первом тексте в 2,5 раза больше, чем во втором. Какова мощность каждого из

алфавитов, с помощью которых записаны сообщения, если известно, что число символов в каждом алфавите не превышает 32 и на каждый символ приходится целое число битов?

Известно число жителей, проживающих в каждом доме

улицы. Нумерация домов проведена подряд. Дома с нечетными номерами
расположены на одной стороне улицы, с четными — на другой. На какой
стороне улицы проживает больше жителей? В ПАСКАЛЕ АВС

Определить время звучания

звукового файла, который занимает на диске 36 Мб. Характеристики
закодированного звука: стерео, глубина 24 бита, частота дискретизации 48 кГц.

Читайте также

Помогите найти ошибки в программе Program Oshibka;

Var a:b;c:Integer;
Begin
Writeln('Введите число ',a);
Readln('a')
b=5
c:=ab;
Writeln('произведение a и b'равно',S);
Readln(a);
End

Помогите найти ошибку , программа работает неполноценно , всё пересмотрел , ошибки не нашёл...Программа в Pascal:Метод выборный.

Program test;
uses crt;
Const
N=5;
var a : array [1..N] of integer;
var i , Max , k , t , f : integer;
begin
For i:=1 to N do
A[i]:=random(8);
write ('Массив');
writeln;
For i:=1 to N do
begin
write (A[i]);
write (' ');
end;
writeln;
For i:=1 to (N-1) do
begin
Max:=A[i];
For k:=i+1 to N do
If (A[k]>Max) then
begin
Max:=A[k];
f:=k;
end;
t:=A[i];
A[i]:=A[f];
A[f]:=t;
end;
write ('Упорядоченный массив');
writeln;
For i:=1 to N do
begin
write (A[i]);
write (' ');
end;
end.
После end должна стоять запятая...это же цикл , надеюсь на вашу помощь...

Помогите найти ошибку , программа работает неполноценно , всё пересмотрел , ошибки не нашёл...Программа в Pascal:Метод выборный.

Program test;
uses crt;
Const
N=5;
var a : array [1..N] of integer;
var i , Max , k , t , f : integer;
begin
For i:=1 to N do
A[i]:=random(8);
write ('Массив');
writeln;
For i:=1 to N do
begin
write (A[i]);
write (' ');
end;
writeln;
For i:=1 to (N-1) do
begin
Max:=A[i];
For k:=i+1 to N do
If (A[k]>Max) then
begin
Max:=A[k];
f:=k;
end;
t:=A[i];
A[i]:=A[f];
A[f]:=t;
end;
write ('Упорядоченный массив');
writeln;
For i:=1 to N do
begin
write (A[i]);
write (' ');
end;
end.

ПОМОГИТЕ НАЙТИ ОШИБКУ В РЕШЕНИИ!!!

Где начать цикл?
с клавиатуры вводится предложение, в котором слова разделены пробелами. определите, сколько слов в этом предложении начинается на букву "а".

Program Pr1;
var s, s1, s2:string;
count, n, i:integer;
begin
writeln('введите фразу');
readln(s);
count:=0;
for i:=1 to length(s) do
begin
n:=Pos(' ', s);
s1:=Copy(s,1,n-1);
s2:=Copy(s1,1,1);
if s2='а' then
count:=count+1;
Delete(s,1,1);
end;
writeln(count);
end.

помогите найти ошибку!


Вы находитесь на странице вопроса "помогите найти ошибку!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.