Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано четырехзначное число. ВЫделить цифры этого числа. Четные цифры сложить,нечетные перемножить. (Использовать mod и \-целочисленное деление)

10-11 класс

Anilegna5564 24 янв. 2015 г., 21:55:53 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Natali081
25 янв. 2015 г., 0:27:23 (9 лет назад)

uses crt;
var pr,sum,e,d,s,t,a:integer;
begin
readln(a);
e:=a mod 10;
d:=(a div 10) mod 10;
s:=(a div 100) mod 10;
t:=a div 1000;
pr:=1;
sum:=0;
if e mod 2 =0 then sum:=sum+e else pr:=pr*e;
if d mod 2 =0 then sum:=sum+d else pr:=pr*d;
if s mod 2 =0 then sum:=sum+s else pr:=pr*s;
if t mod 2 =0 then sum:=sum+t else pr:=pr*t;
writeln(sum);
writeln(pr);
end.


Ответить

Другие вопросы из категории

Два сообщения содержат одинаковое количество символов. Количество информации в первом тексте в 2,5 раза больше, чем во втором. Какова мощность каждого из

алфавитов, с помощью которых записаны сообщения, если известно, что число символов в каждом алфавите не превышает 32 и на каждый символ приходится целое число битов?

Известно число жителей, проживающих в каждом доме

улицы. Нумерация домов проведена подряд. Дома с нечетными номерами
расположены на одной стороне улицы, с четными — на другой. На какой
стороне улицы проживает больше жителей? В ПАСКАЛЕ АВС

Определить время звучания

звукового файла, который занимает на диске 36 Мб. Характеристики
закодированного звука: стерео, глубина 24 бита, частота дискретизации 48 кГц.

Читайте также

Срочно! Дано трехзначное число. Если сумма цифр этого числа превышает 15, то вывести эту сумму. Иначе вывести

произведение цифр этого числа.

Необходимо решение на языке Паскаль. Заранее спасибо!

Разделите точками цифры этого числа группами по три , начиная справа.

Программа получает на вход натуральное число , содержащее не более 100 цифр.
Программа должна вывести то же число , с точками между некоторыми цифрами этого числа.

Примеры входных и выходных данных

Ввод 1000 1.000
Вывод 12345678 12.345.678


Автомат получает на вход два двузначных шестнадцатеричных числа . В этих числах все цифры не превосходят цифру 6 (если в числе есть цифра больше 6,

автомат отказывается работать). По этим числам строится новое шестнадцатеричное число по следующим правилам. 1) Вычисляются два шестнадцатеричных числа – сумма старших разрядов заданных чисел и сумма младших разрядов этих чисел . 2) Полученные два шестнадцатеричных числа записываются друг за другом в порядке возрастания (без разделителей). Пример. Исходные числа: 66, 43. Поразрядные суммы: A, 9. Результат: 9A. Определите, какое из предложенных чисел может быть результатом работы автомата : 1) AF 2) 410 3) 8B 4) 76 (и объясните, пожалуйста, как это решать вообще)) )

1)составить блок-схему поиска двузначных чисел,таких,что если к сумме цифр этого числа прибавить квадрат этой суммы,то получится это число.

2)построить блок схему которая меняет порядок цифр числа на обратный. например было 12345,стало 54321.



Вы находитесь на странице вопроса "Дано четырехзначное число. ВЫделить цифры этого числа. Четные цифры сложить,нечетные перемножить. (Использовать mod и \-целочисленное деление)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.