Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Помогите найти ошибку , программа работает неполноценно , всё пересмотрел , ошибки не нашёл...Программа в Pascal:Метод выборный.

10-11 класс

Program test;
uses crt;
Const
N=5;
var a : array [1..N] of integer;
var i , Max , k , t , f : integer;
begin
For i:=1 to N do
A[i]:=random(8);
write ('Массив');
writeln;
For i:=1 to N do
begin
write (A[i]);
write (' ');
end;
writeln;
For i:=1 to (N-1) do
begin
Max:=A[i];
For k:=i+1 to N do
If (A[k]>Max) then
begin
Max:=A[k];
f:=k;
end;
t:=A[i];
A[i]:=A[f];
A[f]:=t;
end;
write ('Упорядоченный массив');
writeln;
For i:=1 to N do
begin
write (A[i]);
write (' ');
end;
end.

Artem67211 13 авг. 2013 г., 21:11:33 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zulya39
13 авг. 2013 г., 23:32:27 (10 лет назад)

после end же точка ставится а не " ; " вроде бы

+ 0 -
Lisakameneva
14 авг. 2013 г., 0:49:47 (10 лет назад)

да после end точка должна быть

Ответить

Другие вопросы из категории

Пожалуйста помогите с номером 7)))

Буду очень признательна вам :)♥♥

ТЕМА: МАССИВЫ

помогите плиз!

Написать программу расчета среднего арифметического отрицательных элементов в одномерном массиве. Заменить минимальный элемент в одномерном массиве на полученное среднее арифметическое.

1.
4. Подсчитайте за один проход, сколько его элементов равны максимальному элементу.

На вход программе сначала подается значение n<=100 – количество элементов в массиве. В следующей строке входных данных расположены сами элементы массива – целые числа, по модулю не превосходящие 30000. Выдайте количество искомых элементов массива.

Читайте также

Помогите найти ошибку , программа работает неполноценно , всё пересмотрел , ошибки не нашёл...Программа в Pascal:Метод выборный.

Program test;
uses crt;
Const
N=5;
var a : array [1..N] of integer;
var i , Max , k , t , f : integer;
begin
For i:=1 to N do
A[i]:=random(8);
write ('Массив');
writeln;
For i:=1 to N do
begin
write (A[i]);
write (' ');
end;
writeln;
For i:=1 to (N-1) do
begin
Max:=A[i];
For k:=i+1 to N do
If (A[k]>Max) then
begin
Max:=A[k];
f:=k;
end;
t:=A[i];
A[i]:=A[f];
A[f]:=t;
end;
write ('Упорядоченный массив');
writeln;
For i:=1 to N do
begin
write (A[i]);
write (' ');
end;
end.
После end должна стоять запятая...это же цикл , надеюсь на вашу помощь...

1. Дано n чисел. Найти колличество тех, которые делятся на 5, и не делятся на 7.

2. Найти квадраты всех отрицательных чисел среди N заданных.
3. Найти количество чисел, среди N введенных,которые имеют нечетные порядковые номера, а сами являются четными числам.
4. напишите программу для вычисления суммы:
- 1*1!+2*2!+3*3!+....+n*n!
- 1*3+3*5+5*7+...n(n+2)
- 1+11+111+...+111+1-n слагаемых.
Помогите, пожалуйста написать программы для паскаля, очень нужно. Заранее спасибо.

СРОЧНО.Вот код.Это программа не вся ,здесь даны формулы для вычисления массивов, которые и нужно найти.Написал функцию, вроде бы всё нормально, но не могу

понять как присвоить вычисляемые значения массиву.Массивы Y(8), Z(10) , W(15) .Если что, то потом необходимо еще подсчитать общее количество в этих массивах.
program pr_10;
const b1 = 4;
b2 = 6;
c1 = 8;
c2 = 3;
d1 = 5;
d2 = 12;
var i,m:integer ; y,z,w:real;
function fY(i:integer):real;
begin
Y:=b1*sin(2*i)+exp((i-5)*ln(b2));
end;
function FZ(i:integer):real;
begin
Z:=c1*(i-4)+c2*sqr(sin(1.5*i));
end;
function FW(i:integer):real;
begin W:=d1*ln(0.1*i)+d2*exp((3)*ln(i-2.5));
end;
begin
for i:=1 to 8 do
begin

Ym[i]:= Y(i);
writeln('Y = ',y);
end;
end.

помогите написать программу которая из 20 чисел находит максимальное трехзначное число, не кратное 9. если таких чисел нет, писать "нет"

const
N=20;
var
a:array [1..N] of integer;
i,j,max:integer;
begin
for i:= 1 to N do
readln(a[i]);
max:=99;
j:=a[i];
for i:= 1 to N do
if (j>99) and (j<999) and (j mod 9 <>0) and (j>max) then max:=j;
if max>99 then writeln (max) else writeln ('no');
readln;
end.

программа проверяет только последнее число, а не все 20. где ошибка?

Помогите найти ошибки в программе Program Oshibka;

Var a:b;c:Integer;
Begin
Writeln('Введите число ',a);
Readln('a')
b=5
c:=ab;
Writeln('произведение a и b'равно',S);
Readln(a);
End



Вы находитесь на странице вопроса "Помогите найти ошибку , программа работает неполноценно , всё пересмотрел , ошибки не нашёл...Программа в Pascal:Метод выборный.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.