Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составьте программу ,которая позволяет удалить символы t из строки s.Строка s и символ t,который надо удалить,вводятся с клавиатуры

5-9 класс

VladAveryanov 22 июня 2014 г., 17:44:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
анюткажолобова
22 июня 2014 г., 18:31:34 (9 лет назад)

тогда вот, все по букве задания

var
  s : string;
  t : char;
  i : integer;
begin
  readln (s);
  read (t);
  i := 1;
  while (i <= length (s)) do
  begin
    if s[i] = t then delete (s, i, 1)
    else i := i + 1;
  end;
  writeln (s);
end.

+ 0 -
Uuuuuuzya
22 июня 2014 г., 19:38:21 (9 лет назад)

обязательно именно удалять символ в строке? можно просто при выводе фильтровать символы. если важен только результат, то можно так сделать, если решение, то надо удалять.

+ 0 -
Кнопка77
22 июня 2014 г., 22:16:18 (9 лет назад)

Важно решение

Ответить

Другие вопросы из категории

В каждом из приведённых примеров указано четыре объекта.Три из них вошли

в одну группу в некоторой классификации,а один объект -
лишний.Укажите,по какому свойству выполнялась классификация в каждом
примере и какой объект лишний...
а)Днепр,Южный Буг,Амазонка,Ворскла;
б)Хмельницкий,Днепропетровск,Харьков,Кривой Рог;
в)Украина,Россия,Болгария,США;
г)стол,диван,окно,шкаф:
ПРИДУМАЙТЕ САМИ АНАЛОГИЧНЫЕ ПРИМЕРЫ!!!!



Помогите Пожалуйста,ато поставят 2 бала...

1.Привести пример полной,ложной информации

2.Объективно недоступной
3.Актуальной,неполной
4.Доступной,субъективной
5.Достоверной,неактуальной
ПОМОГИТЕЕ ПОЖАЛУЙСТА,СРОЧНО НАДО!!))))))

Читайте также

1.Составить программу, которая определяет номера позиций символа","

2. Составить программу, которая позволяет заменить все гласные символом "*"

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

составьте программу, которая вставляет слово ОБА после каждого слова, заканчивающегося на гласную.

Или

составьте программу, которая определяет на сколько в строке S слов, начинающихся на главную букву больше, чем в строке T

надо решить одну из них

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а)

определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на...

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.



Вы находитесь на странице вопроса "Составьте программу ,которая позволяет удалить символы t из строки s.Строка s и символ t,который надо удалить,вводятся с клавиатуры", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.