Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Pascal (Паскаль). Очень прошу помощи

10-11 класс

Составить программу сортировки массива методом пузырька НО не использовать for
Только через repeat + использовать flag
Всего в программе должно быть 3 переменных:

Jadyra120396 09 окт. 2014 г., 12:17:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
9milisa
09 окт. 2014 г., 13:06:27 (9 лет назад)

program test;
const n = 5;
var i,flag,b:integer;
m:array [1..n] of integer;
begin
b:=1;
for i:=1 to n do
readln(m[i]);
repeat
b:=b+1;
if m[b]<m[b-1] then
begin
flag:=m[b-1];
m[b-1]:=m[b];
m[b]:=flag;
b:=1;
end;
until b=n;
for i:=1 to n do
writeln(i,')',m[i]);
end.

P.S. я использую for только для записи и вывода

Ответить

Другие вопросы из категории

Читайте также

люди помогите решить задачку(паскаль) очень прошу

оценка за четверть решается моя



Вы находитесь на странице вопроса "Pascal (Паскаль). Очень прошу помощи", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.