Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

В двумерном числовом массиве найти количество не отрицательных элементов? Помогите!!!

10-11 класс

Marcotubii 24 марта 2015 г., 21:43:14 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Glebbylatov001
24 марта 2015 г., 23:56:09 (9 лет назад)

Язык Python

A = [[1,-2,3,-4,5],[-6,7,-8,9,0],[0,-9,8,-7,6],[-5,4,-3,2,1]]
cnt = 0
for i in A:
  for j in i:
    if j >=0: cnt+=1
print "Неотрицательных элементов -", cnt

Ответить

Другие вопросы из категории

помогите найти ошибку!
Два сообщения содержат одинаковое количество символов. Количество информации в первом тексте в 2,5 раза больше, чем во втором. Какова мощность каждого из

алфавитов, с помощью которых записаны сообщения, если известно, что число символов в каждом алфавите не превышает 32 и на каждый символ приходится целое число битов?

Известно число жителей, проживающих в каждом доме

улицы. Нумерация домов проведена подряд. Дома с нечетными номерами
расположены на одной стороне улицы, с четными — на другой. На какой
стороне улицы проживает больше жителей? В ПАСКАЛЕ АВС

Читайте также

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

СРОЧНО, ПОЖАЛУЙСТА, НАПИШИТЕ КТО-НИБУДЬ, НА ЗАВТРА НАДО, УМОЛЯЮ, Я УЖЕ 30 РАЗ ЭТО ЗАДАНИЕ ПОСЫЛАЮ, НАПИШИТЕ!!!

1.Дано массив 5*5, заполнить массив случайными числами не больше 30 и найти сумму парных элементов массива, которые находятся под главной диагонали и количество не парных элементов которые находятся над главной диагонали.

Составьте Paskal-программу решение следующей задачи:

Задан массив A(n).Найти сумму и количество чётных отрицательных элементов этого массива

Если в прямоугольной матрице меньше половины столбцов содержит отрицательные элементы, то все элементы с нечетными номерами столбцов умножить на 10. В

противном случае все отрицательные элементы матрицы возвести в квадрат.

У меня получилось вот что:

program s455;
uses crt;
const
m=10;
n=12;
Var
A: array[1..m,1..n] of integer;
i, j, k, s: integer;

Begin
writeln('Enter size');
readln;
s:=0;
for j:=1 to m do
begin
k:=0;
for i:=1 to n do
end;
begin
if a<0 then begin
k:=1;
end;
if k=1 then s:=s+1;
end;
begin;
if k<0
then a[i, j]:=a[i, j*2-1]*10;
else a[i, j]:=a[i, j]*c [i, j]
end;
writeln

Не могу понять в чем ошибка



Вы находитесь на странице вопроса "В двумерном числовом массиве найти количество не отрицательных элементов? Помогите!!!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.