Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дано натуральне число n. визначте кількість цифр у цьому числі

10-11 класс

Nick7775 07 февр. 2016 г., 17:17:31 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ruspodumako
07 февр. 2016 г., 18:47:35 (8 лет назад)

  var m, n: longint;
  k: integer;
  begin 
writeln('Введите число:'); 
 readln(n); 
 m:=n; 
 k:=0;
 while m <>0 do  
   begin   
   inc(k);
m:= m div 10;  
 end;
  writeln('B числе ',k, ' цифр'); 
 readln;
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста))) Мне срочно надо)))

Алгоритм вычисления значения функции

Помогите пожалуйста, а

Написать программу, которая выводит на экран четверостишье:
Буря мглою небо кроет, Вихри снежные крутя.
То как зверь она завоет, то заплачет как дитя.

access

На основе
таблицы «Поставки» сформировать запрос о создании нового поля Розничная Цена,
в котором подсчитывалось бы численное значение из поля Цена, увеличенное
на 20%. Как прописать запрос?

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

1.Дано двузначное число.Определить: a.какая из его цифр больше,первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число.

Определить,равен ли квадрат этого числа учетверённой сумме кубов его цифр. Например, для числа 48 ответ положительный, для числа 52-отрицательный. 3. Дано двузначное число. Определить: a. кратна ли трём сумма его цифр b. кратна ли сумма его цифр числу a. 4. Дано трёхзначное число Определить,равен ли квадрат этого числа сумме кубов его цифр. 5. Дано двузначное число,определить:входит ли в него цифра 3: входит ли в него цифра a.

Задача 1. Счастливые билетики по–ярославски

Есть счастливые билетики по–московски, есть счастливые билетики по–питерски, но мало кто слышал про счастливые билетики по–ярославски. В ярославском общественном транспорте номера билетиков состоят из 2N цифр. Билетик называется счастливым, если ярославская сумма первых N цифр равна ярославской сумме последних N цифр. Требуется найти количество счастливых билетиков по–ярославски для заданного N. На первый взгляд, задача простая, но что же такое «ярославская сумма»? Для заданного числа k найдем сумму его цифр, если получившееся число состоит из двух и более цифр, то найдем сумму цифр этого числа и т. д., пока не получим число, состоящее из одной цифры. Такая сумма цифр называется «ярославской суммой цифр». Билетики нумеруются от 00…000 до 99…999.
Вход: файл input.txt, в первой строке которого записано натуральное число N.
Ограничения: 1 ≤ N ≤ 1000
Выход: файл output.txt, содержащий одно число – количество счастливых билетиков по модулю109+7 (т.е. остаток от деления количества счастливых билетиков на 109+7)
Примеры
input.txt output.txt
1 10
6 110888113
Задача 2. Замощение улицы
Новый мэр Эль-Пасо Авраам Гарфилд решил замостить главную улицу города и для этой работы нанял бригаду рабочих во главе с Джорджем Шерманом. Улица представляет собой полосу длиной 4*N метров. Бригада Джорджа будет покрывать её плитками размера 1*2 метра. Плитки можно укладывать как горизонтально, так и вертикально. Шермана интересует, сколькими способами он может замостить главную улицу Эль-Пасо. Так как это число может быть очень большим, то от вас требуется найти число замощений по модулю 109+7 (т.е. найти остаток от деления количества замощений при делении на 109+7).
Вход: файл input.txt, в первой строке которого записано натуральное число N (ширина дороги в Эль-Пасо).
Ограничения: 0 < N < 113
Выход: файл output.txt, содержащий одно число – количество различных способов замостить улицу плитками 1*2 по модулю 109+7 (т.е. остаток от деления количества способов замостить улицу на 109+7).
Примеры
input.txt output.txt
2 5
3 11
7 781
Пояснение к примерам
Улицу длиной 4*2 метра (первый тест из примеров) можно замостить 5 следующими способами:

Задача 3. Упаковка печенья
На вас, как на главном программисте компании по производству печенья, лежит много ответственных заданий. Одно из них – производство и упаковка печенек должна соответствовать самым высоким требованиям Ярославского Консорциума по упаковке печенья.
В любой момент ваша линия производства выпускает новые печеньки, которые хранятся в печенькохранилище, ожидая упаковки. Время от времени поступают запросы с конвейера по упаковке – отправить из печенькохранилища ту печеньку, которую нужно упаковать. Перед поступлением в хранилище, диаметр каждой печеньки измеряется с точностью до 1 нанометра. На упаковку отправляется печенька, являющаяся медианой среди всех печенек. Что такое медиана? Если мы отсортируем печеньки по возрастанию диаметров, то, если печенек нечетное количество c, то на упаковку идёт печенька на позиции (c+1)/2 в отсортированной последовательности. Если же c – четное число, то печенька на c/2+1 в отсортированной последовательности. Если печеньку отправляют на упаковку, то она пропадает со склада. Ваша задача – промоделировать работу системы упаковки печенек.
Вход: файл input.txt, в каждой входной строке которого содержится либо положительное число d, означающее, что в хранилище поступает новая печенька диаметром d нанометров, либо символ '#', означающий запрос с конвейера по упаковке.
Ограничения: 1 ≤ d ≤ 300 000 000; количество строк ввода не более 600 000; также следует считать, что хранилище пусто до тех пор, пока туда не поступит первая печенька.
Выход: файл output.txt, содержащий несколько строк – после каждого запроса на упаковку в отдельную строку выводится диаметр печеньки, которая отправляется на упаковку.
Примеры
input.txt output.txt
1
2
3
4
#
#
#
# 3
2
1
4
1
#
2
#
3
#
4
# 1
2
3
4





Вы находитесь на странице вопроса "дано натуральне число n. визначте кількість цифр у цьому числі", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.