Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

помогите, программа не работает, нужно разложить 4-хзначное число на цифры

5-9 класс

var a,a1,a2,a3,a4:integer;
begin
write ('vv ch');
read (a);
a1:= a/1000;
a2:= a/100 mod 10;
a3:= a/10 mod 10;
a4:= a mod 10;
write (a1,a2,a3,a4);
end.
где ошибка!!!!????

Kimulya1234 22 февр. 2014 г., 4:00:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
NastyaAsya2000
22 февр. 2014 г., 6:44:28 (10 лет назад)

Если я все правильно понял, нужно "/" заменить на div, т.к. вы используете тип integer.

+ 0 -
Mln1999
22 февр. 2014 г., 9:12:55 (10 лет назад)

Я бы сделал так:
var a,a1,a2,a3,a4:integer;
begin
write ('Введите четырехзначное число: '); read (a);
a1:= a div 1000;
a2:= a div 100 mod 10;
a3:= a div 10 mod 10;
a4:= a mod 10;
writeln ('Первая цифра: ',a1);
writeln ('Вторая цифра: ',a2);
writeln ('Третья цифра: ',a3);
writeln ('Четвёртая цифра: ',a4);
end.
Этот вид более эстетичный ;)

Ответить

Другие вопросы из категории

Читайте также

Ребят сделайте пожалуйста с помощью программы Паскаль задания номер 7.и задание номер 5. Завтра сдавать д.з а у меня программа не работает(( решите и

пришлите решение задач!..Даю хорошие баллы за это задание.Всем большое спасибо!

Электронный термометр измеряет температуру на улице. При температуре от 0 до 10 градусов выдает сообщение «Холодно»; с 10 до 15 выводится

сообщение «Прохладно»; выше 15 градусов – «Жарко». 1. Составьте блок схему данной программы термометра. При каких температурных показателях программа не работает. 2. Записать на алгоритмическом языке

напишите программу в Паскаль чтобы нарисован был светофор)) небольшой, разрисован нужными цветами( жёлтый, зелёный, красный) и сам светофор

серый..Помогите пожалуйста...ставлю спасибо))) надеюсь на вашу помощь)))( программу не большую)



Вы находитесь на странице вопроса "помогите, программа не работает, нужно разложить 4-хзначное число на цифры", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.