Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Pascal ABC.

5-9 класс

Двухмерный массив.
1)вычислить количество чётных элементов
2) сумму элементов столбца по его введённому номеру

Btrchik 28 сент. 2014 г., 3:27:35 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Denis1999978
28 сент. 2014 г., 4:41:06 (9 лет назад)

program sdf;var a:array[1..10000,1..10000] of integer; i,j,k,h,m,n:integer; s:real;beginwriteln('vvedite kolichestvo strok');readln(n);writeln('vvedite kolichestvo stolbtsov');readln(m);writeln('vvedite elementy matricy');for i:=1 to n dofor j:=1 to m doreadln(a[i,j]);k:=0;for i:=1 to n dofor j:=1 to m do if a[i,j] mod 2 = 0then k:=k+1;Writeln('vvedite nomer stolbtsa');readln(h);for j:=1 to m dos:=s+a[j,h];writeln('kolichestvo chetnyh', k);writeln('symma elementov stolbtsa', s);end.

Ответить

Другие вопросы из категории

Какие из перечисленных приложений относятся к приложениям специального назначения?

1.Программы компьютерного моделирования
2.Электронные таблицы
3.Системы управления базами данных
4.Программы для работы в компьютерной сети

ВЫРУЧАЙТЕ ПЛИЗ!!!!!!!!!!!!!!!!!! qbasic

1)дан массив А(8):
-6,4 5,6 -0,1 46,7 7 -3 8 0,23 6
1,1)Сформировать массив B,каждый элемент которого вычисляется по формуле B(I)=a(i)*5
вывести на печать элементы массива B
1,2)вычислить произведение элементов массивов A и B
1.3)вывести на печать 5 элемент массива, А и первый элемент массива В


Упражнение “О честности министров”. Условие: известно и истинно, что народу страны служат сто министров, и каждый из этой сотни либо продажен, либо

честен. Агентству национальной безопасности стало известно, что: (1) по крайней мере один из министров честен; (2) из любой пары министров по крайней мере один продажен. Вопрос: можно ли на основании этих утверждений решить, сколько министров продажны, а сколько - честны?

Помогите пожалуйста!

Перевести из 10-ой в 2,8,16-ю систему счисления с точностью до 3 знака после запятой:
а. 130,158
б. 106,171
в. 119,166

Читайте также

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу,которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.


1) дано четырёхзначное число. вывести максимальную и минимальную цифру. pascal abc

2) дано четырёхзначное число. Что больше: произведение цифр числа или их утроенная сумма. pascal ABC

Я работаю в прграмме Pascal ABC

Вот проверьте здесь гдето ошибка
program abc;
var a,b,c:integer;
begin;
write ('Длина равна=')
read(a);
write ('Ширина равна=')
read(b);
c:=a*b
write ('Площадь='c');
readln;
end.
Мне показало что в строке

Очень срочно. даю 100 пунктов. Pascal ABC. Если не сдам, будет 3 за четверть(((((((((((((( Написать программу, которая

сортирует массив ПО УБЫВАНИЮ и ищет в нем элемент, равный X (это число вводится с клавиатуры). Использовать двоичный поиск.



Вы находитесь на странице вопроса "Pascal ABC.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.