Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Напишите код на паскале.

10-11 класс

Сама задача: посчитать частоту встречаемости каждой буквы алфавита в введенном тексте.

Vgdgvcbxvvghhf 24 февр. 2016 г., 0:57:10 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Chikhranova99
24 февр. 2016 г., 1:46:43 (8 лет назад)

var a:array[1..33] of integer;
s:string;
i:integer;
begin
readln(s);
for i:=1 to length(s) do
if s[i] in ['А'..'Я'] then a[(ord(s[i])-ord('А')+1)]+=1
else a[(ord(s[i])-ord('а')+1)]+=1;
for i:=1 to 33 do
write(a[i],' ');
end.

Ответить

Другие вопросы из категории

Дано А = A716, B = 2518. Найдите сумму A + B.
Задания(Дана величина А, выражающая объем информации в байтах. Перевести А в более крупные единицы измерения информации.)

var a:real;
begin
readln(a);
writeln('В килобайтах' a/1024);
writeln('В мегабайтах' a/(1024*1024));
end. это правельно?если нет,тогда распишите так как у меня написано,чтоб можно было вести и не морочить себе голову.

Читайте также

Пожалуйста помогите!!!

Напишите программу на Паскаль которая даст ответ попадет точка в заштрихованную область или нет

Что нужно дописать в коде на паскале для того чтобы программа выдавала сразу все возможные варианты(их 8)

var
A,B,C:boolean;
begin
for A:=false to true do begin
for B:=false to true do begin
for C:=false to true do begin
writeln ('1 zn'#9#9#9,'2 zn'#9#9#9,'A'#9,'B',#9,'C'#9);
writeln('(A and B) and C'#9#9,'A and (B and C)'#9#9,'A=',A,' ','B=',B,' ','C=',C);
if ((A AND B) AND C = A AND (B AND C)) then
readln;
end;
end;
end;
end.

Есть код на паскале, который считает выражение и запрещает ввод букв. Нужно сделать проверку знаменателя на 0 обоих выражений, и вывести текст в случае

нуля

PascalABC

program aip;
var
fltA,fltB,fltB2:real;
code:integer;
function ip(A:real):real;
var A1:string;
begin
write('Введите значение А= ');


//--------
repeat
readln(A1);
val(A1,A,code);
if (code<>0) then writeln('no');
until (A>0);
//-------
ip:=A;
end;
begin
fltA:=ip(fltA);
fltB:= ((1-2*sin(fltA)*sin(fltA))/(1+sin(2*fltA)));
fltB2:= ((1-tan(fltA))/(1+tan(fltA)));
writeln('Первая формула ',fltB:5:5);
writeln('Вторая формула ',fltB2:5:5);
end.



Вы находитесь на странице вопроса "Напишите код на паскале.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.