Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите составить код (С++) Даны натуральное число п, действительные числа а1 ..., an. В последовательности

10-11 класс

определить количество соседств двух чисел разного знака.

Dashaleonteva 05 марта 2014 г., 9:13:14 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89204925895
05 марта 2014 г., 11:58:05 (10 лет назад)

#include <iostream>
using namespace std;
int main()
{
int res=0,a[100],n;
cout<<"Input N"<<endl;
cin>>n;
cout<<"Input elements."<<endl;
for (int i=0;i<n;i++)
cin>>a[i];
for (int i=0;i<n-1;i++)
if (((a[i]>=0) && (a[i+1]<0)) || ((a[i]<0) && (a[i+1]>=0)))
res+=1;
cout<<res;
return 0;
}

Ответить

Другие вопросы из категории

pascal Задание по теме "Записи"

Массив из записей "Маклер".Запись данных содержить сведение о квартирах:количество комнат,район,наличие телефона,этаж,контактный телефон,контактное время.Обеспечить поиск по указанному району и количество комнат

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Система команд исполнителя Ластик имеет вид:

(Умножение на 2),(Стереть последнюю цифру)
A) числа 7 из числа 361:
Б) числа 14 из числа 457:

1.Дано натуральное число:

a) найти произведение цифр числа б) верно ли, что в данном числе нет данной цифры А (цифру А вводить с клавиатуры)
2. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, а при увеличении на 4 делятся на 5.
3.Из данного натурального числа удалить все цифры А (а вводятся с клавиатуры).

Написать программы в паскале и желательно блок-схему, но можно и без нее.
Помогите пожалуйста)

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.



Вы находитесь на странице вопроса "Помогите составить код (С++) Даны натуральное число п, действительные числа а1 ..., an. В последовательности", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.