Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ массива В ПАСКАЛЕ, ПОЖАЛУЙСТА)

10-11 класс

Дан массив х[N]. Найти наибольший элемент (max). Преобразовать исходный массив таким образом,чтобы все элементы по модулю не равные MAX заменялись нулями,а остальные единицами.

Coolsdew 29 окт. 2014 г., 6:10:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Skrillax
29 окт. 2014 г., 8:16:48 (9 лет назад)

var
 x:array[1..100] of integer;
 i,n,max:integer;
begin
 readln(n);
 for i:=1 to n do
  read(x[i]);
 max:=x[1];
 for i:=1 to n do
  if max<x[i] then
   max:=x[i];
 for i:=1 to n do
  if abs(x[i])<>max then
   x[i]:=0
  else
   x[i]:=1;
 for i:=1 to n do
  write(x[i],' '); 
end.

Ответить

Другие вопросы из категории

Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных
Первая строка входного файла содержит целое число N (1 <= N <= 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Треугольник задан длинами своих сторон – a, b, c. Определить является ли

он тупоугольным, прямоугольным или остроугольным

Сделать разветвляющуюся алгоритмическую структуру.

Читайте также

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала коо

рдинат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!



Вы находитесь на странице вопроса "ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ массива В ПАСКАЛЕ, ПОЖАЛУЙСТА)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.