Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дано 3 числа. Если модуль хотя бы одного из них больше 1, то найти их среднее арифметическое, иначе - их произведение

5-9 класс

Chanelnick 07 марта 2017 г., 4:42:58 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sonehka2015
07 марта 2017 г., 7:00:02 (7 лет назад)

program gt;
var a,b,c,s:real;
begin
read(a,b,c);
if(abs(a)>1)or(abs(b)>1)or(abs(c)>1) then s:=(a+b+c)/3 else s:=a*b*c;
writeln(s);
end.

Ответить

Другие вопросы из категории

Укажите пожалуйста ошибку.

P.S. Программа должна определять максимальное из этих чисел.


var b,c:integer;
function back():integer;
const
a:array [1..10] of byte = (1,2,3,4,5,6,7,8,9,10);
var max,d,m:integer;
begin
max:=-100;
for m:=1 to 10 do;
begin
d:=a[m];
if d>max then max:=d;
back:=max;
end;
end;
begin
writeln(max);
end.

компьютерный вирус А заполняет 1Гб за 1 месяц, вирус В заполняет 1Гб за 2 месяца, вирус С заполняет 1Гб за 3 месяца, вирус D заполняет 1Гб за 6

месяцев. На компьютере одновременно обнаружены сразу все 4 вируса. Сколько гигабайтов они заполнят за 1 месяц?

Читайте также

даны два числа. Если первое число нечетное, то найти сумму кубов, а иначе - куб суммы. даны три числа. Если хотя бы одно из чи

сел - отрицательное, то найти Iа+ b+cI иначе а+b+c +d в корне.

Даны три числа. Если произведение данных чисел - отрицательное, то каждое число возвести в квадрат, иначе найти модуль каждого числа

ПОМОГИТЕ ОЧЕНЬ ПРОШУ

Даны числа a,b,c. Составить программу, выводящую на экран сообщение, в зависимости от того какой треугольник можно построить с такими длина сторон:

равносторонний,равнобедренный или какой либо другой.

Вот ещё одна

Составить программу:Даны а,b,c-целые числа.Если они большн 0-вычислите сумму их квадратов;а если хотя бы одно из них четно-вычислите их сумму и произведение.

Пожалуйста ребят.

Даны действительные числа x, y. Если x и y отрицательны, то каждое значение заменить модулем; если отрицательно только одно из них, то оба значения

увеличить на 0,5; если оба значения неотрицательны и ни одно из них не пренадлежит отрезку [0.5;2,0], то оба значения уменьшить в 10 раз ; в остальных случаях x и y остаются без изменения . Помогите , завтра зачет.



Вы находитесь на странице вопроса "дано 3 числа. Если модуль хотя бы одного из них больше 1, то найти их среднее арифметическое, иначе - их произведение", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.